S500 cannot register manually

I purchased a single S500 and tried to register to accounts via its web interface. I cannot get the phone to register both accounts.

The phone is at 192.168.10.108. I have no idea what I am doing wrong. I chose the manual route rather than auto-provisioning because it seemed simpler since there is only a single phone.

Any suggestions?

FreePBX 13.0.106

Name/username             Host                                    Dyn Forcerport Comedia    ACL Port     Status      Description                      
100/100                   192.168.10.105                           D  Yes        Yes         A  5060     OK (15 ms)                                   
101/101                   192.168.10.105                           D  Yes        Yes         A  5060     OK (15 ms)                                   
102/102                   192.168.10.106                           D  Yes        Yes         A  5060     OK (4 ms)                                    
103/103                   192.168.10.104                           D  Yes        Yes         A  2048     OK (87 ms)                                   
104/104                   192.168.10.107                           D  Yes        Yes         A  5060     OK (16 ms)                                   
105/105                   192.168.10.101                           D  Yes        Yes         A  5060     OK (44 ms)                                   
110/110                   192.168.10.108                           D  Yes        Yes         A  5060     OK (365 ms)                                  
200/200                   192.168.10.104                           D  Yes        Yes         A  2048     OK (27 ms)                                   
201/201                   192.168.10.101                           D  Yes        Yes         A  5060     OK (40 ms)                                   
203/203                   192.168.10.108                           D  Yes        Yes         A  5060     OK (810 ms)                                  
204/204                   192.168.10.107                           D  Yes        Yes         A  5060     OK (18 ms)                                   
205/205                   192.168.10.103                           D  Yes        Yes         A  5060     OK (6 ms)                                    
206/206                   192.168.10.106                           D  Yes        Yes         A  5060     OK (4 ms)                                    
207/207                   192.168.10.105                           D  Yes        Yes         A  5060     OK (16 ms)                                   

sip debug peer 203
No such command 'sip debug peer 203' (type 'core show help sip debug peer' for other possible commands)

Did you mean?

 sip show peer 203


* Name       : 203
Description  : 
Secret       : <Set>
MD5Secret    : <Not set>
Remote Secret: <Not set>
Context      : from-internal
Record On feature : automon
Record Off feature : automon
Subscr.Cont. : <Not set>
Language     : en
Tonezone     : <Not set>
AMA flags    : Unknown
Transfer mode: open
CallingPres  : Presentation Allowed, Not Screened
Callgroup    : 
Pickupgroup  : 
Named Callgr : 
Nam. Pickupgr: 
MOH Suggest  : 
Mailbox      : [email protected]
VM Extension : *97
LastMsgsSent : 0/0
Call limit   : 2147483647
Max forwards : 0
Dynamic      : Yes
Callerid     : "Sylvia Office" <203>
MaxCallBR    : 384 kbps
Expire       : -1
Insecure     : no
Force rport  : Yes
Symmetric RTP: Yes
ACL          : Yes
DirectMedACL : No
T.38 support : No
T.38 EC mode : Unknown
T.38 MaxDtgrm: 4294967295
DirectMedia  : No
PromiscRedir : No
User=Phone   : No
Video Support: No
Text Support : No
Ign SDP ver  : No
Trust RPID   : Yes
Send RPID    : Yes
Path support : No
Path         : N/A
TrustIDOutbnd: Legacy
Subscriptions: Yes
Overlap dial : Yes
DTMFmode     : rfc2833
Timer T1     : 500
Timer B      : 32000
ToHost       : 
Addr->IP     : (null)
Defaddr->IP  : (null)
Prim.Transp. : UDP
Allowed.Trsp : UDP
Def. Username: 203
SIP Options  : replaces replace 
Codecs       : (ulaw|alaw|gsm)
Auto-Framing : No
Status       : UNKNOWN
Useragent    : Sangoma S500 V2.0.4.8
Reg. Contact : sip:[email protected]:5060;transport=UDP
Qualify Freq : 60000 ms
Keepalive    : 0 ms
Sess-Timers  : Accept
Sess-Refresh : uas
Sess-Expires : 1800 secs
Min-Sess     : 90 secs
RTP Engine   : asterisk
Parkinglot   : 
Use Reason   : No
Encryption   : No

I was saying we need to debug the sip traffic to see why it is not registering. That said your output shows the phone registered.

1 Like

If it is registered why does the Sangoma GUI say otherwise? Why is there a diagonal line through the icon for 203 on the Sangoma? When I attempt to dial out, why is there no dialtone and call does not go through?

I have checked the SIP User ID (203) and Password many times.

<--- SIP read from UDP:192.168.10.108:5060 --->
REGISTER sip:192.168.10.38:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.10.108:5060;branch=z9hG4bK358760054
From: "203" <sip:[email protected]>;tag=e989db1cb355fbd
To: "203" <sip:[email protected]>
Call-ID: [email protected]
CSeq: 1 REGISTER
Contact: <sip:[email protected]:5060;transport=UDP>
Max-Forwards: 70
Supported: path
User-Agent: Sangoma S500 V2.0.4.8
Expires: 900
Allow: INVITE, ACK, UPDATE, INFO, CANCEL, BYE, OPTIONS, REFER, SUBSCRIBE, NOTIFY, MESSAGE, PRACK
Content-Length: 0


<------------->
[2016-04-21 14:27:39] VERBOSE[16011] chan_sip.c: --- (13 headers 0 lines) ---
[2016-04-21 14:27:39] VERBOSE[16011] chan_sip.c: Sending to 192.168.10.108:5060 (NAT)
[2016-04-21 14:27:39] VERBOSE[16011] chan_sip.c:
<--- Transmitting (NAT) to 192.168.10.108:5060 --->
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.10.108:5060;branch=z9hG4bK358760054;received=192.168.10.108;rport=5060
From: "203" <sip:[email protected]>;tag=e989db1cb355fbd
To: "203" <sip:[email protected]>;tag=as581c0cda
Call-ID: [email protected]
CSeq: 1 REGISTER
Server: FPBX-13.0.106(13.7.2)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="1c73baac"
Content-Length: 0

`

You are getting 401 unauthorized. Maybe try deleting and rebuilding the extension with a new password. Its definitely kicking back your creds.

I followed your suggestion, created a new extension with a different password, set Account 2 in the web GUI to match those credentials, pushed the SaveSet button and, after the window refreshed, I restarted.

After that the newly added extension was registered. However, now the Account 1’s registration failed!

I am having a similar problem (or the same?)! I believe it’s a bug that needs to be fixed! My S500 account 1 is registered fine when it’s the only account registered. However, when I register Account 2 with a different phone system on the same network, suddenly account 1 unregisters itself and says register failed.
So to summarise:
Account 1: pbxact = 192.168.50.11:5060
Account 2: freepbx = 192.168.50.12:5060
When only account 1 is in use - everything working fine.
When account 2 is enabled and registered, account 1 stops working and says register failed and no matter how many times I change the password and make sure it’s correct, it doesn’t want to register until I disable account 2 and reboot the phone.

Can someone please investigate this as it’s quite a major flaw for people who use multiple accounts.

Thanks

Are you using EPM to configure your phone or hand configuring.

Your issue is if hand configuring you need to set the port for each account to be unique. Not the server port but the local port for each account. EPM does this for you but if you are hand configuring the phone you need to do this.

Hi Tony, thanks for your quick reply!

Yep, you are right - when I changed the port number on the extension to 5061 (from 5060), both accounts that I was trying to register are now successfully registered.

Out of interest, why do they have to be different ports? I did the same thing on our Yealink phone and it registered fine with both accounts straight away - no need to change the port for the individual extension.

This is typical. EPM does this for you and does it for all phones as most phones require each unique account to be on its own SIP port or the phone wont know what a packet is for.

Thanks for the info - didn’t know that.

Hmmm, I just checked my Yealink and both the accounts have 5060 for the SIP port. And both accounts are enabled and working. I didn’t use EPM but manually configured it. Weird…

I think they randomize it in the backend if you set both to the same port. The same thing we are adding to our phones in the firmware on the next release.

1 Like