Runaway calls

Latest distro, asterisk 11.

I have this issue where someone/thing dials a number here, and it leaves a long, like 50 minutes “message”. When you listen to the voicemail, it is a fax machine.

I have tried to prevent this by detecting faxes on inbound routes, and then terminating the call, however, it did not help.

I also added SIP settings as follows, but did not help either:


So, I also blacklisted the offending numbers, but more keep ‘popping up’.

Any idea how I can prevent these runaway calls? Thanks in advance.

stumbled on this thought…why not limit voice-mail length, and found this, so added it.

Go to Voicemail Admin, click on Settings, enter a value in maxsecs (max number of seconds to record a message) then click Submit.