RTP Port Range

I’m using the latest beta 2.11 with Asterisk 11 and need to set the rtpstart and rtpend vaules. They are in rtp.conf but that is auto-generated.

The file says that ";rtp settings are defined in the chan_motif freepbx module"
I couldn’t find anywhere in the GUI to set these vaules.

What is the preferred method to adjust the rtp port range?

Thanks in advance.

It seems that per default it is 10000 to 20000

Yes, that’s what is in the rtp.conf file but my provider wants a larger range.

Sorry at this time if you are using Google voice you will have no control over your rtp range.

I’m not using google voice. I want to change the rtp range in rtp.conf though the gui. Can I do this in the Other SIP Settings section of the Asterisk SIP Settings page? Will these override the values in rtp.conf?

Thanks for your help.

If you aren’t using google voice then you need to uninstall the motif module. There is no way to control the values for rtp in the gui. Once you uninstall the motif module you can set the rtp values manually

Worked! Awesome, thank you!

Hi, I’m using google voice but I want to change the rtp.conf stuff. Is it a requirement for google voice to have that range or is just the module that is always defaulting to those values and there is no way to change that (for now)?


Update core, framework, motif and sipsettings and then you’ll be able to change those values in sipsettings. The information in this thread is heavily outdated.

It worked but now I’m having some strange issue when I set the range between 20000 and 30000. I can receive calls without any problems but when I make a call 30 seconds later it hangs up. I’ll keep testing. Thank you!

That’s not a strange issue, it’s the RTP timeout value.

Did you update your SIP NAT settings?

Hi, thank you for replying. I have the following settings:

Asterisk SIP Settings >
External IP: MY Public IP
Local Networks: My local network /
RTP Port Ranges: 20001 (rtpstart) 30000 (rtpend)

nat: yes
port: 5060
deny: empty
permit: empty

My firewall settings:

External Port 5061 redirects to internal port (my asterisk server) port 5060

External Ports: 200001 to 30000 redirects to internal port ports 200001 to 30000

Any other setting that I may be forgetting?

I really appreciate your help! Thanks!

The ports are 20001-30000



I am having a similar issue. I have updated framework and core but I don’t see motif on the list. Anyways I don’t see anything about rtp ports in the sip settings. I can manually edit it but I am afraid that it will reset later if I don’t do it in the gui.

This is only in Framework 2.11 and Sip settings 2.11

Did you change /etc/asterisk/rtp.conf to reflect that range?

I was also speaking more of your firewall settings.

you can set RTP range from GUI.

from setting-> asterisk sip setting->RTP Port range