RPID no longer working


We have come across an issue where the RPID header is no longer being sent out.

We are running centos 5, asterisk and fPBX

The sip trunk has always had sendrpid=yes
This always worked previously and the remote party header was sent out

Now it doesnt work

We have also tried sendrpid=rpid as well.

Any ideas??


This is now happen across several PBXs running Asterisk 1.8 and freepbx 2.9

The rpid header is no longer being sent, even though sendrpid=yes is set on the trunk

Did you upgrade something before it broke. When it was working what version of asterisk and FreePBX were you using?

yes I upgraded from asterisk 1.6.2 to asterisk 1.8
Freepbx 2.9 worked with 1.6.2 and then it didnt work with 1.8
asterisk is installed from the asterisknow rpms

This may possibly be related to a prior discussion that concerned spurious reinvites that caused disconnects. I haven’t followed up on that (but i did post a bug report at Phillippe’s request). I recall that it was related to the sendrpid=yes command.

It wasnt disconnecting.

If I look at the sip trace, the RPID header is not showing in the sip invite.
It is on the asterisk 1.6.2 boxes though, its only missing from those which have been upgraded from 1.6.2 to 1.8