Route to external IVR with dtmf tone for auto extension dial

Im trying to make this work, Ive tried a few different suggestions that Ive found here but I cant get them to work.

Current IVR option needs to go to Ring Group busy/no answer, transfer to an external IVR followed by entering a 4 digit extension number.

  Ive tried configuring a Misc. Destination with a trunk,  prefix 9999 prepend 866-XXX-XXXX, dial string d(wwwXXXX). However the call routes back to our IVR. Remove string call goes through to IVR. Is this my errror...the string isnt complete? 

Ive also created a chan_pjsip extension with a dial option LOCAL/[email protected],300,D( ww1234 ) however its the same result and routes back to our IVR.

Ive read I can create a custom extension under admin/custom ext. However i do not see a place to add a dial option. If someone wouldnt mind providing some corrective criticism, Id be greatful. I may have over thought this and need to take a step back and empty my cup, start fresh.

In FreePBX, most of the obvious Asterisk methods don’t work, because FreePBX usually overrides the Dial options with its own computed values.

Create a Custom trunk with Custom Dial String set to
PJSIP/[email protected]
according to which channel driver your trunk uses. You cannot use LOCAL or other indirect channel. For now, leave Asterisk Trunk Dial Options blank, with Override set.

Define an Outbound Route with match pattern 9999, pointing to the custom trunk.

From an internal extension, dial 9999 and you should reach the remote IVR.

Next, change Asterisk Trunk Dial Options for the custom trunk to

Dial 9999 again and you should reach extension 1234 on the remote system.

Finally, set up a Misc Destination with Dial set to 9999 and route your failover to that.

For your test, ask the Ring Group members to not answer, call in from your mobile, select the IVR option and with luck the external extension 1234 should answer.

Thank you Stewart, I’m configuring this now and will give it a go.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.