Route extension outside call


We have 3 landlines, each line with its own public number, what we need to do is set up a group of extensions when they call outside use just one number and other group of extensions use other, we have a rule that uses 9 for to get outside line.

Like Extension 101,103,105 at dial 9 + 1800… will use land line 274.832.xxxx and the group 110,120,115 use 9 + 1800… will use line 274.735.xxxx

I know we can create an individual route for each public number like 8 + 1800 for use 274.832 and 9 + 1800 for use 274.735…

but we need something automatic to avoid users using the wrong one.

Are these analog lines? If so , how are they connected to the PBX?

we have an E1, we use a SANGOMA VEGA100.

E1’s don’t use DID specific B channels, you need to set your outbound CallerID appropriately before sending calls to the Vega

1 Like

The outbound call is working fine, currently, we have 9 + 1800… for the call use 274.832… and 8 for the call use 274.735… but the issue is the people keep using the wrong digit like extension 110 should use 8 for all his outgoing calls, but most of the time he dials 9 1800… in which use the other number.

Assuming that the Vega is passing caller ID correctly, you shouldn’t have to do anything special.
Each extension should have Outbound CID set to the outgoing number you wish to use.
Assuming that the Outbound Route does not have Override Extension set and the Trunk has Allow Any CID set, then the Outbound CID for the calling extension should be sent on the trunk.

If that’s not working, please explain how your ‘9’ and ‘8’ routes are configured.

depending on your phones, you might be able to simply set them to use a dialing prefix automatically to that it Forces 8- or 9- or 7- on their outbound calls.

Trouble is that the wet-ware are pressing the wrong prefix button :wink:

wetware cant shoot itself in the foot if you take the bullets out of the gun.

if the hardphone prepends an 9- to outbound calls, they cant mis-dial.

Hello, the Vega is not the problem, it relates to the routing of the FreePBX, I define on outbound route 9 on dial partners and use the route cid for to get out using 274.832 and create another with the dial partner 8 and the CID 274.735. all calls go out correctly the problem is the people, because by muscle memory they dial 9 for an outside call, only when they are concentrating dial 8. when it needs it.

Any guide line who?

sorry, im not familiar with Which devices you are using, which firmware, or their specific configuration.

Please explain what you are trying to accomplish.

Each extension has an Outbound CID setting. If your Outbound Routes and Trunks are set up correctly, the number in Outbound CID will be sent when that extension makes an external call.

Most modern systems are set up so external numbers can be dialed directly, without using a prefix such as 9 or 8. Depending on the country you are in, it may be possible to set it up so an initial 8 or 9 is permitted, but not required.

If a user makes calls on behalf of multiple people, departments or organizations, you could use a prefix to select the outgoing number, but (if your hardware permits), it is usually better to use multiple line buttons on the phone. For example, if you make calls for both Acme Widgets and Best Service, set up two extensions on your phone, with line buttons labeled Acme and Best. These buttons can also distinguish incoming calls so you can answer appropriately.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.