Root Password Changed By Itself


(United States) #1

I’m running the current “recommended” version 15.0.17.43,12.7.8-2107-3.sng7 (None of the other versions work, please fix for VMWare. Was there testing?) and strangely today I’m unable to login to the root password. I used this same password for all my systems in my testing environment. I ran three batches of updated, the 1st and 2nd group updates and restarts worked just fine, but this last one. I recall it was a single module. The issue seems to have appeared after I updated it. I tried various “default” passwords I found by searching the forums, none worked. Only I have access to the system, I’ve been working in the IT Field for 20 years.
If there is some log you would like to have me upload? I can. But if this happens to others users in a production environment it might be scary.

I was able to fix the problem with the Troubleshooting menu also added a few other system accounts.


(Simon Telephonics) #2

That’s the latest; I’m curious what version you’d prefer to run?

if you think the password issue is update related then there might be evidence either in the yum.log or /var/log/messages

Anecdotally, I updated several FreePBX 15 Distro systems to current on Sunday and did not see anything like this.


(United States) #3

Thank you very much for your response.
I would like to run FreePBX 15 (Asterisk 18) This would be what I would consider to be the latest version… The recommended is 2 major versions behind Asterisks. The 18 version fails to recognizes the VMware disks on the automated install and requires a manual disk slicing, but looks like there was no option to do a manual disk slicing and install. TBH I didn’t spend much time on it after the failures, but doing same/same installations vs. the “Recommended” I had to move forward with what worked.

After testing password changes, there is nothing in /var/log/messages.
Here is the update log
Aug 06 22:30:19 Installed: ssh_keys-3.1-81.sng7.noarch
Aug 07 20:30:49 Updated: asterisk16-core-16.19.0-1.sng7.x86_64
Aug 07 20:30:50 Updated: asterisk16-addons-core-16.19.0-1.sng7.x86_64
Aug 07 20:30:50 Updated: asterisk16-addons-mysql-16.19.0-1.sng7.x86_64
Aug 07 20:30:50 Updated: asterisk16-voicemail-16.19.0-1.sng7.x86_64
Aug 07 20:30:50 Updated: asterisk16-dahdi-16.19.0-1.sng7.x86_64
Aug 07 20:30:50 Updated: asterisk16-doc-16.19.0-1.sng7.x86_64
Aug 07 20:30:50 Updated: asterisk16-addons-ooh323-16.19.0-1.sng7.x86_64
Aug 07 20:30:50 Updated: asterisk16-addons-bluetooth-16.19.0-1.sng7.x86_64
Aug 07 20:30:52 Updated: wanpipe-7.0.32-1.sng7.x86_64
Aug 07 20:31:07 Updated: kmod-wanpipe-7.0.32-1.sng7.x86_64
Aug 07 20:31:07 Updated: asterisk16-addons-16.19.0-1.sng7.x86_64
Aug 07 20:31:07 Updated: asterisk16-16.19.0-1.sng7.x86_64
Aug 07 20:31:07 Updated: asterisk16-resample-16.19.0-1.sng7.x86_64
Aug 07 20:31:07 Updated: asterisk16-curl-16.19.0-1.sng7.x86_64
Aug 07 20:31:07 Updated: asterisk16-ogg-16.19.0-1.sng7.x86_64
Aug 07 20:31:07 Updated: asterisk16-odbc-16.19.0-1.sng7.x86_64
Aug 07 20:31:13 Updated: sangoma-pbx-2107-3.sng7.noarch

This was more of an FYI.
Thanks!


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.