Roadmap for asterisk 13.16?

hi, i am trying to get a polycom to work with my freepbx 14 (asterisk 13.15.1) system. All my phones are configured for sip-tls and srtp. i can receive calls on the polycom with no issue, but i don’t get any audio when i make a call. i get this error in asterisk

[2017-06-01 15:41:22] WARNING[25516][C-0000006c]: res_srtp.c:415 ast_srtp_unprotect: SRTP unprotect failed with: authentication failure 110

I have found this on the asterisk site and I think it is the bug I am experiencing, looks like it is fixed in 13.16, so I was wondering when freepbx might include 13.16

https://issues.asterisk.org/jira/browse/ASTERISK-26979
thanks

Asterisk 13.16 just came out 2 days ago to stable. it takes us a week or so to test and publish new builds.

@GameGamer43 might be able to provide more info

After you get it working, please post how you did it for the rest of us.
I have wanting to do this for Mitel phones.

Both Asterisk 13.16.0 and 14.5.0 are in our pipeline and are awaiting some basic QA before they get released as stable.

There is currently a community issue where-as it’s been reported that Asterisk 13.16 crashes Rasp-pi systems.

For more information see:
https://issues.freepbx.org/browse/FREEPBX-14944
and
https://issues.asterisk.org/jira/browse/ASTERISK-27026

Ug, it;s always something! LOL, hope the raspi issue get resolved quickly, i could really use 13.16

thanks for all the info

and I will post back if 13.16.x fixed my issue

Let us know. Our internal rpms work but a few pi users are having serious issues.

Andrew, sorry, i should have been clearer. i will post back when freepbx releases asterisk 13.16 and let you know if it fixes my issue. i really don’t have a way of trying it unless freepbx provides it

thanks

Asterisk 13.16.0 should be available in our yum repositories.

Bryan, sorry for my ignorance, i am only familiar with doing system updates via admin/module admin/system updates. when i check online here, there are no updates available. is there another way to do it?

Provided you are running the FreePBX Distro (unmodified), you can always use yum:

yum update asterisk13*

Alternatively, you can always get the current version of Asterisk using asterisk-version-switch.
https://wiki.freepbx.org/display/PPS/Changing+Major+Asterisk+Versions+on+the+Fly

Lorne, i am running distro 14 beta (FreePBX 14.0.1rc1.21)…will that do?

Brian, I just did a

yum list available asterisk*

and i only see 13.15.1 available

i am on FreePBX 14.0.1rc1.21…if that makes a difference.

any idea when 13.16 will be in the freepbx 14 repo?

thanks

I’m seeing Asterisk 13.16 in the dev repo:

[[email protected] ~]# yum list asterisk13
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Available Packages
asterisk13.x86_64                  13.16.0-1.sng7                   sng7-testing

@xrobau is that by design, or should it be in the sng-pkgs repo?

Lorne, this is what i see:

[[email protected] ~]# yum list asterisk13*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Installed Packages
asterisk13.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-addons.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-addons-bluetooth.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-addons-core.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-addons-mysql.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-addons-ooh323.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-core.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-curl.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-dahdi.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-doc.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-flite.x86_64 2.2.1.3-3_3118e6a.sng7 @anaconda/1703
asterisk13-odbc.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-resample.x86_64 13.15.1-1.sng7 @sng-pkgs
asterisk13-voicemail.x86_64 13.15.1-1.sng7 @sng-pkgs
Available Packages
asterisk13-alsa.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-configs.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-devel.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-ogg.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-pgsql.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-snmp.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-speex.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-sqlite3.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-tds.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-voicemail-imapstorage.x86_64 13.15.1-1.sng7 sng-pkgs
asterisk13-voicemail-odbcstorage.x86_64 13.15.1-1.sng7 sng-pkgs

yum clean all

same result

[[email protected] ~]# yum clean all
Loaded plugins: fastestmirror
Cleaning repos: sng-base sng-epel sng-extras sng-pkgs sng-updates
Cleaning up everything
Cleaning up list of fastest mirrors
[[email protected] ~]# yum list asterisk13
Loaded plugins: fastestmirror
sng-base | 3.6 kB 00:00:00
sng-epel | 4.3 kB 00:00:00
sng-extras | 3.4 kB 00:00:00
sng-pkgs | 3.4 kB 00:00:00
sng-updates | 3.4 kB 00:00:00
(1/8): sng-epel/7/x86_64/group_gz | 170 kB 00:00:00
(2/8): sng-base/7/x86_64/group_gz | 155 kB 00:00:00
(3/8): sng-extras/7/x86_64/primary_db | 151 kB 00:00:00
(4/8): sng-pkgs/7/x86_64/primary_db | 372 kB 00:00:00
(5/8): sng-epel/7/x86_64/updateinfo | 793 kB 00:00:00
(6/8): sng-updates/7/x86_64/primary_db | 4.8 MB 00:00:02
(7/8): sng-epel/7/x86_64/primary_db | 4.7 MB 00:00:02
(8/8): sng-base/7/x86_64/primary_db | 5.6 MB 00:00:03
Determining fastest mirrors
Installed Packages
asterisk13.x86_64 13.15.1-1.sng7 @sng-pkgs

it looks like Lorne is using sng7-testing…is that the difference?

Hmm, it appears that the build has not made it to the production repo. I’ll re-push it. Sorry about that!

Edit: It’s in the production repository. There may be other issues with yum mirrors. Looking harder.
Edit2: Looks like it was just a synchronisation delay. Everything seems fine now!

rob, thanks for your help on this. i was able to update to 13.16. i will post back if 13.16 fixes my polycom issue…thanks again!