Ringgroups-2.8.0.3 Confirm Calls bug

I have a system running ringgroups-2.8.0.3

When checking the “confirm calls” box, you can either leave the default remote announce message or play a custom one. No matter which option, when the remote phone answers, the DTMF is not accepted.

I thought at first i was having a one way audio issue, but upon unchecking the box, i was able to have a normal conversation. This obviously is an immensely important reason to use ringgroups (for keeping a cell phone voicemail from answering a call from a queue).

Surely someone has run into this issue before, and or may know of a fix. Is this only me, only 2.8.0.3 (if so, how does one downgrade back to 2.8.0.2 without losing data).

I saw other posts about multiple issues with 2.8.0.3. Is it just a bad release altogether?

per the other thread, set that in the trunk configuration.

It should not have to be in the general settings as the each trunk should be configured as is required.

The only things that should have to rely on the defaults would be anonymous sip calls.

it appears that the “SIP Settings” configuration tool doesn’t by default put a “dtmfmode=auto” in to sip.conf. I added it via the GUI and all is working. The SIP provider Vitelity suggested to check for that before I submitted a trouble ticket to them.

Hopefully one day soon that will get added as a default. It would have sure saved me a lot of time and trouble :slight_smile:

I keep answering myself to a certain degree, but I think i’ve narrowed it down to an Asterisk bug. I don’t know where to go from here.

I’m running freepbx 2.8.1 and asterisk 1.8.2.3

what I have noticed is that there is something that isn’t quite right when running a macro on an outbound call until the macro exits. It’s almost like it hasn’t fully answered.

in macro-confirm i bypassed the “read” statement and the rest of the macro ran fine. For what it is worth, Authenticate also seems to have this same issue.

It appears through testing that the Read() and Authenticate() commands both suffer from the same problem.

If i simply do an “exten => s,n Set(INPUT=1)” in place of either of the sets below, it completes (without user input)

exten => s,n,Authenticate(1,1,${MSG1})
exten => s,n Set(INPUT=1)

or

exten => s,n,Read(INPUT,1,4)

It’s like it is in one way audio mode until the macro exits after this part

exten => 1,n,Set(__MACRO_RESULT=)
exten => 1,n(exitopt1),MacroExit()

I don’t know what would cause that. I’m hoping someone on here knows more about how to make a patch or a workaround for this.

I have also tried using ringallv2, and have also set up a virtual extension and used the followme settings within the extension and get same results.

Here is a snippit of my log while the greeting is playing and in the silence i press 1, but it appears that it doesn’t “hear” it.

-- Executing [[email protected]:4] BackGround("Local/[email protected];1", "custom/mybiz-acceptsupport,m,en,macro-confirm") in new stack
-- <Local/[email protected];1> Playing 'custom/mybiz-acceptsupport.slin' (language 'en')
-- Executing [[email protected]:5] Read("Local/[email protected];1", "INPUT,,1,,,4") in new stack
-- Accepting a maximum of 1 digits.
-- User entered nothing.
-- Executing [[email protected]:6] GotoIf("Local/[email protected];1", "0?,1:t,1") in new stack
-- Goto (macro-confirm,t,1)
-- Executing [[email protected]:1] GotoIf("Local/[email protected];1", "0?toolate,1") in new stack
-- Executing [[email protected]:2] Set("Local/[email protected];1", "LOOPCOUNT=2") in new stack
-- Executing [[email protected]:3] GotoIf("Local/[email protected];1", "1?s,start:noanswer,1") in new stack
-- Goto (macro-confirm,s,4)
-- Executing [[email protected]:4] BackGround("Local/[email protected];1", "custom/mybiz-acceptsupport,m,en,macro-confirm") in new stack
-- <Local/[email protected];1> Playing 'custom/mybiz-acceptsupport.slin' (language 'en')

I looked to see if i could find any differences in how the ringgroups were set up from this machine compared to my other machine (old machine was a Trixbox)

from extensions_additional.conf:
exten => _RG-2051-.,1,Macro(dial,${DB(AMPUSER/2051/followme/grptime)},M(confirm^custom/mybiz-acceptsupport^^2051)${DIAL_OPTIONS},${EXTEN:8})

from old system (trixbox,extensions were 3 digit not 4) extensions_additional.conf:
exten => _RG-301-.,1,Macro(dial,60,M(confirm^custom/mybiz-incomingcall^^301)m(default)t,${EXTEN:7})

not suer of significance between these two… looks like new system uses more variables?

I have tried the resolution but it doesnt fix the problem. Is the only way to fix to upgrade to 2.9?