Ring Timer Mystery

Hi All!

I have a rather simple FreePBX version that I installed a few months ago on Centos 6.3. I've updated the modules every few weeks or so.

The ring timers for extensions don't change the ring duration.

Whether you call an extension via an IVR (press 2) or as a direct extension (press 6102) I am unable to change the ring time from 2 or 3 rings before it goes to voicemail.  The extensions are very basic SIP extensions that correspond to Grandstream GXP2100 IP phones.

In FreePBX Advanced Settings > Dialplan and Operational > Ringtime Default is set to 13.  I've tried changing the default and the extension setting many times, especially after module updates. E.g., Extensions > Extension 6102 > Extension Options > Ring Time doesn't actually affect the Ring Timer whether it's set to default, 8, or any other value.

I've read through a lot of the posts in the various forums, googled for solutions and looked for possible causes, but have found nothing.

I'm sure that someone in the community is clever enough to know how to solve this or tell me how to troubleshoot it. :)

Thanks in advance,
-Jeff Mings in Honolulu

I should also mention that this installation was from the distro. Everything else works, including trunks, IVR, etc.
-Jeff Mings in Honolulu

Experienced Virtual Machine users know that the only benchmarks you can trust from a VM are those run with a physical stopwatch because VMs often run their clocks faster than real-time. This was happening with the FreePBX system in a VirtualBox VM. I had to multiply the desired ring time in seconds by about 6 to receive the desired ring time! A ring time of 30 is about 6 rings. I had never tried such high ring time numbers, since they seemed ridiculous. Watching the asterisk messages go by gave me a clue to what was actually happening. :slight_smile: