Ring Groups Not working


I’m using FreePBX and Asterisk (Ver.

I am having a problem with ring groups. I’m trying to set up memory hunt or ringall strategy. I create a ring group 600, I put in the extensions that I would like to have ring and then i set the destination if no answer. For now I just have the destination as put on hold forever. I set my inbound route destination to Ring Group 600.

When i make a call to it, it just instantly fails over to destination if no answer. If I disable the ring group then the phone will ring just fine.

Anyone have any ideas what can be going on here? I tried it with memory hunt and ring all and the same outcome.

Not sure if this is relating to it but when I called this is the only thing that showed up in the log

[Aug 5 11:59:09] WARNING[5160]: res_agi.c:1618 launch_script: Failed to execute
’/var/lib/asterisk/agi-bin/dialparties.agi’: File does not exist.

Any help is appreciated.

Ok, just a few after posting this, I did find the solution. I’ll post it if anyone else comes across this.

It turns out that, that file in the error i listed above (dialparties.agi) was in fact missing.

Here is what I did:
cd /usr/share/asterisk
sudo cp agi-bin/dialparties.agi /var/lib/asterisk/agi-bin/

Then tried it and it worked!