Ring groups do not work

I upgraded of my FreePBX to 2.10 and I am having the issue.
If I restart asterisk, as a service (service asterisk restart), the following error in the log:

– Launched AGI Script /usr/share/asterisk/agi-bin/dialparties.agi
dialparties.agi: Failed to execute ‘/usr/share/asterisk/agi-bin/dialparties.agi’: Permission denied

I using:
asterisk-voicemail-plain-1.8.12.2-1.el6.x86_64
asterisk-apidoc-1.8.12.2-1.el6.x86_64
asterisk-1.8.12.2-1.el6.x86_64
asterisk-voicemail-1.8.12.2-1.el6.x86_64
asterisk-mysql-1.8.12.2-1.el6.x86_64
asterisk-fax-1.8.12.2-1.el6.x86_64
asterisk-dahdi-1.8.12.2-1.el6.x86_64
asterisk-ooh323-1.8.12.2-1.el6.x86_64
asterisk-devel-1.8.12.2-1.el6.x86_64

Ring groups works properly only if I restart the amportal (amportal restart)

Permissions

-rwxr-xr-- 1 asterisk asterisk 1872 Jun 22 15:40 checksound.agi
-rwxr-xr-- 1 asterisk asterisk 32609 Jun 22 15:40 dialparties.agi
-rwxrwxr-x 1 asterisk asterisk 32609 Dec 15 2011 dialparties.agi.0
-rwxrwxr-x 1 asterisk asterisk 32609 Dec 15 2011 dialparties.agi.1
-rwxr-xr-- 1 asterisk asterisk 13303 Jun 22 15:40 directory
-rwxrwxr-x 1 asterisk asterisk 13303 Dec 15 2011 directory.0
-rwxrwxr-x 1 asterisk asterisk 13303 Dec 15 2011 directory.1
-rwxr-xr-- 1 asterisk asterisk 6750 Jun 22 15:40 directory.agi
-rwxr-xr-- 1 asterisk asterisk 10452 Jun 22 15:40 directory.lib.php
-rwxr-xr-- 1 asterisk asterisk 5683 Jun 22 15:40 enumlookup.agi
-rwxrwxr-x 1 asterisk asterisk 5683 Dec 15 2011 enumlookup.agi.0
-rwxrwxr-x 1 asterisk asterisk 5683 Dec 15 2011 enumlookup.agi.1
-rwxr-xr-- 1 asterisk asterisk 1613 Jun 22 15:40 fixlocalprefix
-rwxrwxr-x 1 asterisk asterisk 1613 Dec 15 2011 fixlocalprefix.0
-rwxrwxr-x 1 asterisk asterisk 1613 Dec 15 2011 fixlocalprefix.1
-rwxr-xr-- 1 asterisk asterisk 2003 Jun 22 15:40 list-item-remove.php
-rwxrwxr-x 1 asterisk asterisk 2003 Dec 15 2011 list-item-remove.php.0
-rwxrwxr-x 1 asterisk asterisk 2003 Dec 15 2011 list-item-remove.php.1
-rwxr-xr-- 1 asterisk asterisk 5376 Jun 22 15:40 page.agi
-rwxr-xr-- 1 asterisk asterisk 10262 Jun 22 15:40 pbdirectory
-rwxrwxr-x 1 asterisk asterisk 31772 Jun 20 11:06 phpagi-asmanager.php
-rwxrwxr-x 1 asterisk asterisk 65947 Jun 20 11:06 phpagi.php
-rwxr-xr-- 1 asterisk asterisk 5914 Jun 22 15:40 queue_devstate.agi
-rwxr-xr-- 1 asterisk asterisk 21211 Jun 22 15:40 sql.php
-rwxr-xr-- 1 asterisk asterisk 20540 Jun 22 15:40 user_login_out.agi

Hi

Looks like the permission IS correct tho.

Perhaps you can try to #su asterisk (or whatever user you’ve setup to run Asterisk as) and try to execute that script and see what gets thrown. Probably as user asterisk, you can’t even go into that directory meaning the permission is not recursive to all sub folders of /var/lib/asterisk

Also, looking from above, assume asterisk is running as user:group asterisk:asterisk

Just to be sure, IS ASTERISK RUNNING AS ASTERISK?

ps -ef |grep asterisk

Hi, thanks for quick reply.

I execute that script, and permissions is OK.

[[email protected] ~]# su asterisk -
bash-4.1$ /var/lib/asterisk/agi-bin/dialparties.agi

VERBOSE “Starting New Dialparties.agi” 1

Then I checked permissions, in all subfolders (/var/lib/asterisk/), everything is OK

I am interested in the process safe_asterisk, it runs from root by default?

[[email protected] ~]# ps -ef | grep -i asterisk
root 25665 1 0 17:13 pts/1 00:00:00 /bin/sh /usr/sbin/safe_asterisk -U asterisk -G asterisk
asterisk 25668 25665 26 17:13 pts/1 01:35:11 /usr/sbin/asterisk -f -U asterisk -G asterisk -vvvg -c
asterisk 25742 1 0 17:13 ? 00:00:00 -bash -c cd /var/www/html/admin/modules/fw_fop && /var/www/html/admin/modules/fw_fop/safe_opserver &
asterisk 25744 25742 0 17:13 ? 00:00:00 sh /var/www/html/admin/modules/fw_fop/safe_opserver
asterisk 25745 25744 0 17:13 ? 00:02:11 /usr/bin/perl /var/www/html/admin/modules/fw_fop/op_server.pl

The problem is relevant. I can say that the previous version of the asterisk was not such a problem.