Ring Groups Broken?

Yesterday I ran the upgrades and now the distro version is: FreePBX Distro 6.12.65-15. I also switched to Asterisk version 12 via the command line.
My ring groups are now doing something strange.
They ring the extension exactly how I want them to but they don’t play the ringing for the incoming caller. They just hear “dead air” until someone picks up.
If I change the option to have it play hold music it works but ring it will not.
Any suggestions?

You can set record in the inbound route for the DID you are using.


Thanks for your reply. Record on the inbound route is set to allow. What setting would you like me to change it to? Also, why would that make a difference for ringing?

If you meant as a diagnostic, when I call from outside I can hear that its not ringing. It’s just silent untill they pick up. (Unless hold music set on for the ring group. Then the caller hears the hold music).

Sorry I didn’t understand.

Sorry to noodge, but does anyone have any suggestions? Is there more information I could provide that would help?
Thank you.

That is odd, I wasn’t responding to this thread!

I suspect that your Asterisk dial options are different and your old system was set for inband ringing.

You may also need to answer the channel first.

Is there a way to modify these settings from the gui? If so, where?

All right, time for the white flag.

While I need ringing I can only make the music on hold options work. I obtained a sound file of a ringing phone, created a new music on hold catagory with only that file and set the ring group to that music on hold catagory.

I still have no idea what about the upgrades broke the ring groups’s ringing, but at least I have the functionality I need.

Check Advanced Settings, Asterisk Dial Options, and make sure that there’ s lower case “r” in there…

There already was an “r” there.
I have ran the scripts to upgraded to the current distro and updated the FreePBX modules and now all is well.
I am not sure what was broken and what fixed it, and I guess I never will.
All the best!

Thanks, AdHominem.

The dial options are currently set to “tr” is there anything else you
could suggest?

I’ve run into the same problem. I can call DIDs and hear the ringing w/o any issues, but when our PBX is utilizing CFC (Call Flow Control) and is in ‘Night Mode’, the calls are being routed to a Ring Group. When that happens, the callers do not hear the ringing but the folks in our facility can hear the phones ringing . We have an IAX route to the facility PBX, and when I call utilizing the IAX trunk, I can hear the ringing. ‘Ring’ is selected for ‘Play Music On Hold’, I have tried ‘default’, and ‘none’ as well - can’t hear the ringing on any of those. I’ve tried Tt, and Ttr as ring strategies with no luck. Don’t know where else to look…