Ring Groups and Extensions not updating until reboot

I am trying to add an extension and update a ring group in FreePBX v and whenever i add an extension it doesnt show up in Sip Show Peers until the server is rebooted. Same issue with updating ring groups. This just started recently. We have a developer in Vietnam who works remotely on the server but they have not been much help as of lately. I was hoping someone else has ran across the same issue.

Thanks! Much Appreciated.

What happens if you do a:

asterisk -rx 'dialplan reload'

That will reload the dialplan not the sip peers. Even then, unless there was custom dialplan that was added, it wouldn’t reload any dialplan for the saved changes. Until FreePBX writes them out, they don’t exist in Asterisk.

The OP came into the IRC room and confirmed that hitting “Apply Config” after making changes didn’t do anything but doing an fwconsole restart did. The OP was then asked to do another test and try fwconsole reload which would cause updates to be written out and all services reloaded (like “dialplan reload”, etc) without fully restarting the services. The OP was also told to confirm that Asterisk was running as the right user (not root)

We never got any followup for either of those last two requests. So either this is some bug or this “developer” has mucked around with the system and broken how it normally works. I’ve seen this in the past quite a bit.

Sorry i couldn’t reply to the IRC yesterday, I got caught up in some other projects during the day. Our developer ended up restarting asterisk at about 7PM last night and it seems to be working again and i asked them for a solution to the problem as it seems like the problem still exists. I’m Guessing like you said they changed something they shouldn’t have and it mucked up the system. Our system integrates into our CRM and it pushes calls that come in to a module that shows incoming calls on our CRM.

You really need to stop rebooting the server. You are rebooting to make things stop and restart, the command I gave you yesterday fwconsole restart does exactly that.

This is Linux, rebooting isn’t something that needs to happen to make things “stop/restart”. Continual reboots can cause issues.

The server isnt physically getting rebooted.

Then what do you mean by “rebooted”? And I wasn’t just referring to your last reply. I was referring in general based on the conversation last night.

Also, restarting just Asterisk isn’t enough.

Restarting Asterisk. We haven’t physically rebooted it in a few weeks. To make things more clear. I inherited this phone system about two months ago when the other IT guy who mainly managed maintenance and updates got let go. Since then i have worked with our developer to get some things sorted out. We have been using FreePBX for about 5 years. We just updated to the latest version back in July. So my terms in restarting asterisk / freepbx may be a little off.

You need to use the right words. They have meaning and people take them for their meanings.

This makes it sounds like you rebooted the server. Your topic of this thread makes it sound like you are rebooting the server. How you spoke in the IRC room yesterday was all about rebooting.

Restarting Asterisk != Rebooting Server. As well then this goes back to what you were told yesterday by @jameswf you need to restart Asterisk via “fwconsole restart/start/stop” you cannot start Asterisk up via the standard Asterisk start up FreePBX must have full control and must run Asterisk as the user asterisk not root.

So basically the reason “Apply Config” isn’t “working” and things work when Asterisk restarted is because FreePBX _does not have permission to restart/reload Asterisk when the Apply Config process is being done. This 100% explains why the changes seem to work once Asterisk is restarted because that’s the only step FreePBX could not do.

Make sure things are running as the right users and that this box is starting services up in the proper order and permissions on boot up.

Sorry about that. I have been a windows admin for about 14 years and now just getting into Linux.

That explains a lot about the issues we have been having. I am guessing Asterisk is running as root then.

I received this back from our developer this morning.

After Asterisk restart, you need to run following command:
$ fwconsole start xmpp
$ fwconsole start ucp

Never had to do that before it just worked perfectly fine upon startup.

JFC, no. fwconsole restart/start/stop DOES IT ALL. It shuts all the services down in the proper order, it brings them all back up in the proper order. It makes sure everything is properly set and ready to go. You should not have to do all this individually.

Is this an ISO based install?

I wasn’t included on the install of the pbx. But it is hosted with Cyberlynk’s FreePBX hosting and as far as i know it was installed by them? I could be totally wrong but that’s how i interpreted it.

When i did a fwconsole restart yesterday it errored out and UCP and XMPP didnt start. They had to be started manually. This leads me to believe they broke something.

When you say “they” are you referring to Cyerlynk? I’m not going to buy that over the “developer” who seems to not understand how any of this works or has provided any real help.

Honestly, the only time I’ve seen these types of issues in ISO/Distro installs is when the “admin/developer” before me totally screwed the pooch and made changes without understanding how FreePBX works.

I was referring to they as our developer broke something. I know our developer did not install FreePBX they barely provide any support they are in Vietnam. It had to be the IT guy before me.