Ring group to time condition


(Nightbreed) #1

Can anyone please help me wrap my head around what I’m trying to accomplish?
I configured the front desk phone with a “Support” BLF key that transfers calls to the support ring group. There are two people (extensions) in this ring group, including myself and another person. I work Mon-Thu and the other person works Wed-Fri. We all started working from home due to COVID-19 and obviously I don’t want my phone to ring on Fridays and the other person’s phone to ring on Mon & Tue. The problem is I’ve already configured the “Support” ring group BLF key on the phone and don’t have remote access to change it.
Can anyone recommend ways to accomplish this?


(Itzik) #2

I’d delete that ring group and recreate it as a queue, then make use of the dynamic agent feature. Log in when it’s your shift.


(Nightbreed) #3

Thanks, I’ll look into that. Haven’t dicked around with queues yet, but I’ll give it a shot.


(Moussa) #4

Try Calendar Module + Find Me/Follow Me.

  • Add the time you work to the Calendar
  • Assign silent ring (sound) on the phone to the old extension
  • Add new extension for your phone
  • Go to he old extension >> Follow-Me list and add the new extension there.

The front desk phone will hit the “Support” BLF key that will (silently) ring (your + your friend) old extensions (Ring Group) but the new extension will actually ring based on the days you work.

https://wiki.freepbx.org/display/FPG/Calendar+Module


(Nightbreed) #5

Hmm, interesting. I’ll check that out as well. Thanks Moussa.


(Nightbreed) #6

@PitzKey I think the queue dynamic agent feature will totally work, thanks for your suggestion. Is there a way to set a ring strategy for agents in the queue? My boss asked me to have all support calls going to him first.


(Itzik) #7

Depending on how many agents you have and how long you want the call ring by each agent and how long you want the call to wait in the queue before failing over.

Let’s say you have a max wait time of 30 seconds, and you want it to ring first 15 seconds by your boss (when he is logged in) and then the rest 15 seconds to the other tech in the the queue.
Then I’d use the wrandom ring strategy and set the boss with penalty of 0 and the other techs with a penalty of 1.
Then set the agent timeout to 15 seconds, retry to 0.

Additionally, I would set the queue capacity options: Join Empty = No, Leave Empty = Yes. And then set the failover to a backup ring group or queue which rings everyone before going to voicemail.
That way, the caller won’t have to wait 30 seconds in an empty queue.

Queues are very powerful, and can sometimes be tricky to understand, the wiki has a ton of information https://wiki.freepbx.org/display/F2/Queues+Module+User+Guide and I suggest you getting your hands a little dirty, try it before rolling it out in production.

Feel free to come back here with your questions.

Much luck!

Keep in mind, changing ring strategy on an existing queue, some strategies requires a asterisk restart (fwconsole restart) in order to work.


(Nightbreed) #8

@PitzKey Thank you so much for the information, it really helps! I meant to say my boss wants the new guy to take the calls first, then me. He absolutely doesn’t want to take support calls haha. Same thing applies though. I’ve got some extra Yealink phones, so I’ll play around with the timing & agent and capacity options, thanks! I’ve only worked with Freepbx since last fall, it’s really amazing all of the stuff you can do with this software.


(Nightbreed) #9

So I’ve been playing around with the dynamic agents and I’m a little confused of what’s going on. I set up two extensions as dynamic agents using the wrandom ring strategy. Both agents are logged into the queue.
601,1
602,0
I transfer the call to the 600 queue and it rings 602 first and then 601 second, perfect. But the next time I try it rings 601 first. Shouldn’t it ring 602 first everytime with this ring strategy and the member’s penalty like I set?


(Itzik) #10

Was that queue set to a different ring strategy before changing to wrandom?


(Nightbreed) #11

It was set to the default ringall before I changed it to wrandom. I think this problem happened then, but now I can’t remember for sure. I changed it to linear and restarted asterisk to see that flow, but that isn’t what I’m after so I changed it back to wrandom. I didn’t restart asterisk after changing it back to wrandom from linear. So let me try that and test again and I’ll report back. Thanks


(Nightbreed) #12

I changed the ring strategy back to wrandom and restarted asterisk:

  1. first try it rang 601,1 (me) first and 602,0 second
  2. rang 601,1 first and 602,0 second
  3. rang 602,0 first and 601,0 second

Any idea what’s going on here?


(Itzik) #13

How did you restart Asterisk? can you post a screenshot of the queue config?


(Nightbreed) #14

fwconsole restart


(Itzik) #15

Sorry, the config in the GUI.


(Nightbreed) #16


Screenshot%20from%202020-03-23%2007-04-46


(Nightbreed) #17

I think this is the config you suggested. It seems like it should work so I dunno.


(Nightbreed) #18

Hi @PitzKey, thanks for your help. I couldn’t get the wrandom with dynamic agents to work properly. Last time I tested it:
1st try - 602 first, then 601
2nd try - 601 first, then 602
3rd try - 601 first, then 602
4th try - 602 first, then 601

I think I got it all working like I want by just creating another queue for myself that it will failover to.


(Alejandro) #19

I would recreate the queue using the settings you want.

Sometimes, queues can get “stuck” with certain settings.


(Nightbreed) #20

@Ajhad I’ll try that right now! Thanks!