Ring group forwarding to nested ring groups

Hi All,

I have the following setup:

Ring Group 6100 - Inbound calls comes here - routes ext 9019, then, after 10 seconds, group 6001

Ring Group 6001 - contains Ring Group 6002,6003 - voice mail 9001 if non avail.

Ring Group 6003 - contains 10 SIP Numbers
Ring Group 6002 - contains 10 SIP Numbers

The calls goes straight to voice mail of 9001 after 10 second. Here is the parts of the debug that I think can help:

dialparties.agi: Starting New Dialparties.agi
dialparties.agi: Caller ID name is ‘99843000’ number is '99843000’
dialparties.agi: Methodology of ring is ‘ringall’
– dialparties.agi: Added extension 9019 to extension map
– dialparties.agi: Extension 9019 cf is disabled
– dialparties.agi: Extension 9019 do not disturb is disabled
– dialparties.agi: dbset CALLTRACE/9019 to 99843000
– dialparties.agi: Filtered ARG3: 9019
– <SIP/oss-in-00000046>AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:7] Dial(“SIP/oss-in-00000046”, “SIP/9019,10,tTrxM(auto-blkvm)”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/9019
== Extension Changed 9019[ext-local] new state Ringing for Notify User 9092
– SIP/9019-00000047 is ringing
– Nobody picked up in 10000 ms

– Goto (ext-group,6001,1)

dialparties.agi: Methodology of ring is ‘ringall’
– dialparties.agi: Added extension 6003 to extension map
– dialparties.agi: Added extension 6004 to extension map
– dialparties.agi: Added extension 6005 to extension map
– dialparties.agi: Added extension 6006 to extension map
– dialparties.agi: Added extension 6007 to extension map
– dialparties.agi: Extension 6003 cf is disabled
– dialparties.agi: Extension 6004 cf is disabled
– dialparties.agi: Extension 6005 cf is disabled
– dialparties.agi: Extension 6006 cf is disabled
– dialparties.agi: Extension 6007 cf is disabled
– dialparties.agi: Extension 6003 do not disturb is disabled
– dialparties.agi: Extension 6004 do not disturb is disabled
– dialparties.agi: Extension 6005 do not disturb is disabled
– dialparties.agi: Extension 6006 do not disturb is disabled
– dialparties.agi: Extension 6007 do not disturb is disabled
dialparties.agi: EXTENSION_STATE: 4 (UNKNOWN)
dialparties.agi: Extension 6003 has ExtensionState: 4
– dialparties.agi: Checking CW and CFB status for extension 6003
– dialparties.agi: dbset CALLTRACE/6003 to 99843000
dialparties.agi: EXTENSION_STATE: 4 (UNKNOWN)
dialparties.agi: Extension 6004 has ExtensionState: 4
– dialparties.agi: Checking CW and CFB status for extension 6004
– dialparties.agi: dbset CALLTRACE/6004 to 99843000
dialparties.agi: EXTENSION_STATE: 4 (UNKNOWN)
dialparties.agi: Extension 6005 has ExtensionState: 4
– dialparties.agi: Checking CW and CFB status for extension 6005
– dialparties.agi: dbset CALLTRACE/6005 to 99843000
dialparties.agi: EXTENSION_STATE: 4 (UNKNOWN)
dialparties.agi: Extension 6006 has ExtensionState: 4
– dialparties.agi: Checking CW and CFB status for extension 6006
– dialparties.agi: dbset CALLTRACE/6006 to 99843000
dialparties.agi: EXTENSION_STATE: 4 (UNKNOWN)
dialparties.agi: Extension 6007 has ExtensionState: 4
– dialparties.agi: Checking CW and CFB status for extension 6007
– dialparties.agi: dbset CALLTRACE/6007 to 99843000
– dialparties.agi: Filtered ARG3: 6003-6004-6005-6006-6007
– <SIP/oss-in-00000046>AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:4] NoOp(“SIP/oss-in-00000046”, “Returned from dialparties with no extensions to call and DIALSTATUS: NOANSWER”) in new stack

– Executing [[email protected]:11] NoOp(“SIP/oss-in-00000046”, “Checking if ext 9001 is enabled: “) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/oss-in-00000046”, “1?s-NOANSWER,1”) in new stack
– Goto (macro-vm,s-NOANSWER,1)
– Executing [[email protected]:1] Macro(“SIP/oss-in-00000046”, “get-vmcontext,9001”) in new stack
– Executing [[email protected]:1] Set(“SIP/oss-in-00000046”, “VMCONTEXT=default”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/oss-in-00000046”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/oss-in-00000046”, “”) in new stack
– Executing [[email protected]:2] VoiceMail(“SIP/oss-in-00000046”, “[email protected],u”””) in new stack
– <SIP/oss-in-00000046> Playing ‘vm-theperson.ulaw’ (language ‘en’)

After posting I tried adding ‘#’ to the numbers and all worked…

Thanks !