Ring Group Bailing Early

So I have several ring groups defined. Each one has RingAll for its members. And after the max of 300 seconds, callers are then forwarded to a particular IVR.

When I was testing this out for a new site location this afternoon, after a little over a minute of ringing my test call hit an automated message that my party wasn’t answering at this time. With an error code. Unfortunately I didn’t jot that down. It didn’t sound like an Asterisk canned recording. I suspect perhaps my SIP trunking provider is intercepting the unanswered call?

Here’s the call as seen in the Asterisk log --> Pastebin Trace. I can make more test calls in later when the site is closed for business. To capture the SIP messages back and forth…

Looking at the logs I don’t see an Asterisk recording playing so I can only assume it’s a SIP trunking provider mechanism coming into play. I’ll look into that on Monday. At least based on what I see going on.

Calls to a ring group don’t answer the channel and your provider probably requires the call to be answered before x seconds. There are options in the Inbound Route to enable Signal Ringing and Force Answer, one the other or both of those options may allow your ring group to work as expected.


Thanks for the tip! I will try that and test out again.

1 Like

I tweaked those settings. Same result. I opened a ticket with my SIP trunking provider (SIP.US), so I’ll see what they have to say. I am making the test calls from my AT&T wireless phone. And the automated message that plays seems to be there’s. The only difference is the error code at the end is 058T for my test calls. Weirdness…

So I opened a ticket with SIP.US. The support rep said their only timeout setting is that any connected SIP call that surpasses 4 hours is disconnected due to their assuming it’s a hung call and it’s cleared to free up the channel.

Making a test call from a Spectrum landline resulted in similar behavior. After about a minute I don’t hear an automated message, but just dead air and the call is disconnected.

For now I’m just dropping the max ring time for the rings groups from 300 seconds down to 60 seconds before hitting the IVR. Figure if no one at the sites pick up a ringing call after a minute then that’s sufficient.

I was the SIP provider’s mechanism after all. Their reply below.

Alright so the answer is yes, there is a timer where if we do not receive a 200 OK ​ from your equipment we will send a CANCEL and terminate the call. I believe the solution to this is to use a queue instead of a ring group. You can set the queue up to ring all the phones in the same way, but I believe the queue will force an immediate 200 OK ​ to us.

Confirmation of my guess above. The ‘Force Answer’ option on the inbound route really should work as well.

I saw the signal ringing option but not the force answer option under advanced settings for the inbound route. FreePBX v13. I would try that if I could find it?

It’s a 14+ feature. In older versions we enable fax detection to do the same thing.

1 Like

This worked like a champ when I enabled that feature. Beats having to build a more complex queue for what’s just a basic RingAll ring group. Thanks for the help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.