Ring Group Alerts on Digium D70 phone not working

Hello all,

I am trying to setup a different ring for calls routed through a ring-group.

I’m using the default Digium ring for the phones and the Office ring for the calls going through the ring group.

I have “office” in the Alert Info box in the Ring Group. I have also tried office inside <>
I am using the digium phone extension
There is a alert defined in the digium phone all with an alert info of "office"
When I call the ring group, I see a SIPAddHeader with the string “Alert-Info: office” as the second argument.
The phones ring with the default Digium ring.

The res_digium_phone_devices.conf file shows the following section


and the phones that are being called by the ring group have the alert-2 defined as


I’m on Freepbx 13.0.167
using Digital Phone Module for Asterisk Version 13.0_3.1.0

Thanks for any help.

Solved the issue.

For some reason - the phones required a factory reset in order to pick up the new alerts.

I guess when in doubt, factory reset.