Rewrite CID when calling to specific extention forwarded to outside

Hi all,

For a serval day’s I’m playing with some challenge;

I like to forward calls for a single extension to a cellphone. For so far no problem, even not to send the original CID with it. But now I like to make some setup that if people call to this extension, there will be send one static CID out to the cellphone, no matter or the call is from internal or external.

Did anybody know how I can fix this? Other extensions who forward calls to a cellphone still need to send the CID with them.

Who know a solution? Hope there will somebody who can explain how to setup.

Thanks for all reply’s!!

Do you have a CID set for each extension? it should be passing that.

Hi WizardOfDos,

Thanks for your reply. Off course I set a CID for each extension. What I try to create is:

Incoming caller (e.g. CID 3140xxxxxxx) -> inbound route to custom extension -> extension uses custom technology; local/[email protected] to Cell Phone -> cellphone will show one single CID what I definite in the PBX.

On this moment there is the CID of the caller (e.g. CID 3140xxxxxxx) showing by the Cell Phone. Here needs just one CID so I can identify via witch route the call will coming in.

Do u know how to fix this?

Thanks!

As the previous poster stated: Use FollowMe or a Ring Group - depending upon which feature you need.

Both features have the follwoing option:
Change External CID Configuration

choose “Fixed CID Value” and enter the Fixed Caller ID

I tried and tried and tried… But… Without success. Did a clean install of FreeBPX again on some other machine and tried again.

I add a ring group, in this ring group the extension what’s mapping to a cell phone but the CID what’s appearing is still the number of the caller and not the CID I set in the “Change External CID Configuration - Fixed CID” field.

Did I miss something?

What is your trunk type / provider?

Be sure you don’t have an override CID set on FPBX Trunks or on the provider.