retrieve_conf failed

I finaly have FreePBX running on my OpenZ container but there is this error I can’t fix. I think this is related with another error. While googling the error code, I found that checking the pass in manager.conf and amportal.conf and then restarting amportal could help.

While tryig this, I figured out that there is an error when I try to restart amportal :

astrundir in ‘/etc/asterisk’ is set to but the directory does not exists.[/quote]

I tried few things I found on forums to fix this but it still doesn’t work. Do you have any idea where it could come from ?
Thanks for your help.

I finally fixed Asterisk which is running correctly. FreePBX status print :

[quote]Reload failed because retrieve_conf encountered an error: 1
Added 2 days, 23 hours, 34 minutes ago

Running retrieve_conf --debug returns

[quote]Mon, 23 Jul 2012 15:12:05 +0200 - Failed to login.
[FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting[/quote]

The [admin] password (manageR.conf) and the AMPMGRPASS (amportal.conf) are the same.

The Asterisk status is ERROR on freePBX.

Any clue ?

What version of FreePBX?

If 2.9 or later /etc/asterisk/freepbx and /etc/asterisk/manager.conf must match.

I’m using FreePBX
I do not have any file named /etc/asterisk/freepbx or freepbx.conf. There is a freepbx.conf file in /etc/ but there is only the database informations in it. They are correct and are the same as the one written in /etc/amportal.conf.

I tried several things as moving or changing the name of this file (depending on what I could find on Google) but it still doesn’t work.

Ok, you are right, this is only the DB settings. You change the manager passoword from the advanced settings module.

It is all resident in the DB so don’t touch amportal.conf. It is written out from the DB and only present to provide data for legacy apps.

I think that I can only change the FOP password and the portal admin password (ari password ?) through the advanced settings. I didn’t find anything related with Asterisk.

Did you click the check boxes for read only and advanced settings?

Oh well, didn’t see that… I changed the password in the settings but I stil can’t run retrieve_conf for the same reason… I restarted everything just to be sure.

What is the solution? Ever since I have upgraded to the latest core module, I am having the same issue.