Retrieve_Conf encountered an error: 1 + Issues with CDR's

Hi there,

I am multiple issues with Freepbx at the moment. I must explain I barely have any knowledge on Freepbx and using Linux at all so ill try my best to answer any questions you have. I started a new job and I had it put onto me, as I like to learn new things. Now for my issues:

Whenever I press Apply config when I have made a change I get "Reload failed because retrieve_conf encountered an error: 1. I run the following commands as Root (Logging in using sudo su root)

service asterisk stop
Amportal restart

When I run those, I can then press apply config and it works no problem, however, the call recordings stop working in the CDR. I have asked someone (who has better knowledge of Linux than me) to see if the calls are stored somewhere on the server after I run those commands, and they are not stored, but the previous recordings are there.

What I have found is if I run Service asterisk stop and service asterisk stop, It makes the call recordings work again but If i need to make any changes and press apply config, I get the retrieve_conf error again.

Its so frustrating! If anyone can help I would really appreciate it.