Restored from back-up getting: Reload failed because retrieve_conf encountered an error: 255

We had our PBX stolen and had to restore. Thanks for back-ups, or so I thought untill I installed official FreePBX 14 (what we where running before) with both Asterisk 13, also tried 14 with the exact same error.

Dashboard gives retrieve_conf failed, config not applied, Reload failed because retrieve_conf encountered an error: 255

Looking at the logs I see

exit: 255
Unable to continue. SQLSTATE[42S22]: Column not found: 1054 Unknown column 'calendar_enable' in 'field list' in /var/www/html/admin/modules/findmefollow/Findmefollow.class.php on line 753
#0 /var/www/html/admin/modules/findmefollow/Findmefollow.class.php(753): PDOStatement->execute(Array)
#1 /var/www/html/admin/modules/findmefollow/functions.inc.php(1141): FreePBX\modules\Findmefollow->get('1000')
#2 /var/www/html/admin/libraries/usage_registry.functions.php(300): findmefollow_getdestinfo('ext-local,1000,...')
#3 /var/www/html/admin/libraries/usage_registry.functions.php(351): framework_identify_destinations(Array, Array)
#4 /var/lib/asterisk/bin/retrieve_conf(817): framework_list_problem_destinations(Array, false)
#5 {main}

And no I did not set it up/install, the person that did it is on leave and out of touch for the next week.

Being a new to VoIP I tried Google with no luck or any idea what I should do. Any hints welcome.

HI!

Maybe a reinstall/update of findmefollow would work… It looks like a column was not added to the database…

Please try

 fwconsole ma install findmefollow

At the command line…

Good luck and have a nice day!

Nick

1 Like

You got to be kidding me :), that worked… forever in your debt.

Sounds like you restored a 13 system on to 14

1 Like

You cannot backup/restore data from different versions of the system. Even the minor numbers on the versions make a difference and can cause the error you got.