Restore Failed

Starting restore. :=log_dir'/var/log/asterisk'
Initializing Restore... :=log_dir'/var/log/asterisk'
Running pre-restore hooks, if any... :=log_dir'/var/log/asterisk'
Restoring files (this may take some time)... :=log_dir'/var/log/asterisk'
File restore complete! :=log_dir'/var/log/asterisk'
WARNING! :=log_dir'/var/log/asterisk'
Web Root restore not detected, not restoring module table :=log_dir'/var/log/asterisk'
You should run "fwconsole moduleadmin upgradeall" to ensure system integrity :=log_dir'/var/log/asterisk'
Restoring astDB... :=log_dir'/var/log/asterisk'
Restoring Settings complete :=log_dir'/var/log/asterisk'
Running post-restore hooks, if any... :=log_dir'/var/log/asterisk'
Cleaning up... :=log_dir'/var/log/asterisk'
Restore complete! :=log_dir'/var/log/asterisk'
Reloading... :=log_dir'/var/log/asterisk'

I am restoring a backup to the same system that the backup was originally created from

The restore APPEARS to go perfectly, however, nothing is restored – no extensions, no SIP Trunks, no routes, nothing

The only clue that something may have gone sideways is the line ‘’ that appears in the otherwise successful looking output from the restore

Anyone seen this before? Pretty nervous that I’m going to have to recreate this entire system

Bump? anyone seen this before?

I opened up the tarball and I can see my extension configurations in there, so I know it has the data. I don’t know why it won’t restore

Surprised no replies :frowning:

Usually people help out pretty quick. maybe this is unusual case. Let me know if I need to provide more info


Have you looked inside the backup file to see what it contains?

It is possible to setup a backup that backups essentially nothing, what does your backup file contains and are the file sizes different from 0?

Good luck and have a nice day!


hey marbled, thanks for the feedback

I have looked inside the backup and I can see the files have sizes (non zero)

there is a mysql dump in there and a bunch of asterisk conf files with the data i need restored inside them

Still no idea why it wont restore, if I knew how to manually restore this I would just do that. I assume I just need to import this mysql file and drop all the asterisk files in the right folder, but i dont want to mess anything up yet if I can get it to work the way it should

You would also need to restore the astdb.sqlite3 database from the presumably included astdb file. the manifest files are pretty well black-magic AFAIK but processed by the restore php file process (/var/lib/asterisk/bin/restore.php). I would enable debugging and watch the commandline operation

ehhh I’m sure I’ll miss steps if I go the manual route. Do you think thats all? MySQL restore, sqlite restore (not even sure how to do that but ill look it up) and then dump all the static files into their places?

Hoping to get help on why the actual restore module failed, cant find any more debug info in the logs on it

I added a couple of lines that might help

1 Like


I looked at the code and the messages you get (except for the weird… which seems to be some sort of excessive verbose debugging seem to suggest this runs properly…

If you try

asterisk -rvvvvvvvvvvvvvvvvvvvvvvvvv
database show

do you get anything?

This should show your extensions, conferences, blacklist, etc…

Under /etc/asterisk does anything appears to have been restored?

Good luck and have a nice day!


Thanks @Marbled

database show shows all the AMPUSERS, thats it

tomorrow I am going to spin up a new freepbx (fresh install) and try restoring to that

I also tried fwconsole reload but no luck


Hey Andrew do you have any ideas on this??

I created a brand new FreePBX 13 install today and tried to install from my FreePBX 13 backup.tar.gz

The dialog shows that everything went smoothly, but NOTHING was restored!

Inside the backup I can see my configurations are there

I’m really at a loss

“database show” on the fresh install server shows a bunch of AMPUSER lines with the extensions, but inside FreePBX > Extensions none are seen there


Did you ever, at any time, set up a remote database?

Thie log entries you have, except for the additional chatter, seem normal so is it possible that there is some sort of remnant of a remote database somewhere in the advanced settings?

Good luck and have a nice day!


Never setup a remote db

Restored to a brand new freepbx install like i said and nothing showed up after the restore finished — no sip trunks no extensions no ring groups etc

But asterisk -rvvvvvvv database show — ampusers show up but thats it

“database show” shows only astdb content AFAIK…

FreePBX > Extensions most likely only uses MySQL/MariaDb, not astdb…

Can you try

mysql -u root
use asterisk
select * from devices;

(Followed by Ctrl-D to quite)

Do you see your extensions (minus virtual) there?

Good luck and have a nice day!


1 Like

Thanks for your help, I gave up and rebuilt the entire system lol couldn’t wait any longer.

I’ve lost faith in FreePBX backup module. I’ll have to do some testing backup/restore to see if that was an isolated issue or what. Never did figure it out