Restore 13.0.197.14 to new server 15.0.16.27


(Ronnie) #1

I am attempting to restore from a 13 version to a newly created 15 version.

I performed a backup of the old server without CDR, then did a restore on the new server and all appears to go ok with only one error noted.

SQLSTATE[HY000]: General error: 1 near “COMMENT”: syntax error

However, after I apply the config I do not see any changes to the configuration.

Thanks for any advice!


(John Jarrett) #2

I just did a couple upgrades to new hardware and one was 13 to 15. I did exactly what you did and was lucky. However, make sure you have the latest edge backup and restore module available for both systems. That’s the only advice I can give.


(Ronnie) #3

John,

Thanks for the info. I had upgraded the new server to edge, but had not done that to the old server. I am moving the backup file over as I type this.

When the restore is done is there anything special you had to do other than go to another tab and Apply ?


(John Jarrett) #4

There was. Non of my voicemails in extensions was enabled and email addresses were also not there. One admin user in user config did not come over but everything else did. This was 13 to 15. In 14 to 15 my custom sounds, IVRs, didn’t make it over. Again voicemails were not enabled but I think the emails were included.

Anyway, I just double checked everything and things worked as they should.


(Ronnie) #5

Thanks again…

I have been retired from the IT business since 2007 and I am a member of a group with the Assemblies of God called MAPS RVers and also a member of Royal Rangers with the AG. I do volunteer work at churches and camps and they provide us an RV slot with hookups for our work.

This is a small system that I installed about 4 years ago at the national Royal Rangers camp and it crashed. I did not have time to run up to Missouri so the shipped me the server. I have the recovered and repaired the data on the old system but decided to build them another server.

I am using OSS for the endpoint manager and it does not appear that FreePBX backs up or restores the config for it. Only have about 10 extensions and very little voicemail so I will manually set those up. At least I got the old drive back to normal so I can have the new webpages and old webpages side by side to setup the new one.

Thanks again for the info!!


(Lorne Gaetz) #6

See this thread Restore Fails with timeout

@VoIPTek did you open a bug ticket as requested?


(Ronnie) #7

Lorne, Thanks for the info. I removed OSS Endpoint Manager from the old server, ran a backup, restored the file to the new server and it appears all is there!!

Too Bad that is is not noted in the new release, it would have saved me a few days…

I will open a ticket!


(Ronnie) #8

The Dev team issued a new backup version, 15.0.8.72, in Edge early this morning. Unfortunately it did not solve the problem for me, same error.


(Philip Joseph) #9

There is new version( backup 15.0.8.73) available which has the fix to solve this issue

Thanks
Philip Joseph


(Ronnie) #10

Yes, a “fix” was issued and I appreciate it but it is not a complete fix as it just ignores the OSS Endpoint tables during the restore. This does allow a restore to work but then you must recreate he extensions in OSS Endpoint, which is ok if you only have a few but a pain when you have a lot more than a few

Hopefully the DEV team will properly fix the problem Thanks for your work on this issue.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.