Restapps not working because of endpoint dependency

Restapps fails because of endpoint not being up to date but module updates don’t show any new version for endpoint. UCP is inaccessible due to an error message with restapps.

fwconsole ma install restapps
Detected Missing Dependency of: endpoint 15.0.52.6
Downloading Missing Dependency of: endpoint 15.0.52.6
Processing endpoint
Verifying local module download…Verified
Extracting…Done
Module endpoint successfully downloaded
Installing Missing Dependency of: endpoint 15.0.52.6
Create symlink…Done
Checking database tables…Done
Migrating tables as required…Done
Checking Settings and Defaults…Done
Generating Configs…Done
Downloading Firmware…Done (Background)
Generating CSS…Done
Installed Missing Dependency of: endpoint 15.0.52.6
Dependency module endpoint version 15.0.52.6 is Enabled
Unable to install module restapps:

  • EndPoint Manager module version 15.0.52.6 or higher is required, you have 15.0.39.55
    Updating Hooks…Done
    Chowning directories…Done

fwconsole setting MODULEADMIN_SKIP_CACHE 1
Changing “MODULEADMIN_SKIP_CACHE” from [0] to [1]
[[email protected] ~]# fwconsole ma listonline
No repos specified, using: [standard,commercial,unsupported,extended] from last GUI settings

±---------------------±-----------±--------------------------------------------±------------±----------+
| Module | Version | Status | License | Signature |
±---------------------±-----------±--------------------------------------------±------------±----------+
| accountcodepreserve | 13.0.2.2 | Enabled and up to date | GPLv2 | Sangoma |
| adv_recovery | | Not Installed (Available online: 15.0.52) | Commercial | |
| allowlist | | Not Installed (Available online: 15.0.12) | GPLv3+ | |
| amd | 15.0.3 | Enabled and up to date | GPLv3+ | Sangoma |
| announcement | 15.0.3.13 | Enabled and up to date | GPLv3+ | Sangoma |
| api | 15.0.9 | Enabled and up to date | AGPLv3+ | Sangoma |
| areminder | 15.0.14.26 | Enabled and up to date | Commercial | Sangoma |
| arimanager | 15.0.3.13 | Enabled and up to date | GPLv3+ | Sangoma |
| asterisk-cli | 14.0.4 | Enabled and up to date | GPLv3+ | Sangoma |
| asteriskinfo | 15.0.14 | Enabled and up to date | GPLv3+ | Sangoma |
| backup | 15.0.21.2 | Enabled and up to date | GPLv3+ | Sangoma |
| blacklist | 15.0.2.20 | Enabled and up to date | GPLv3+ | Sangoma |
| broadcast | 15.0.21 | Enabled and up to date | Commercial | Sangoma |
| builtin | | Enabled; Not available online | | Unsigned |
| bulkhandler | 15.0.4 | Enabled and up to date | GPLv3+ | Sangoma |
| calendar | 15.0.4.23 | Enabled and up to date | GPLv3+ | Sangoma |
| callaccounting | 15.0.27 | Enabled and up to date | Commercial+ | Sangoma |
| callback | 15.0.12 | Enabled and up to date | GPLv3+ | Sangoma |
| callerid | 15.0.16 | Enabled and up to date | Commercial | Sangoma |
| callforward | 15.0.16 | Enabled and up to date | AGPLv3+ | Sangoma |
| calllimit | 15.0.5.6 | Enabled and up to date | Commercial | Sangoma |
| callrecording | 15.0.7.28 | Enabled and up to date | AGPLv3+ | Sangoma |
| callwaiting | 15.0.4.6 | Enabled and up to date | GPLv3+ | Sangoma |
| campon | 13.0.4.1 | Enabled; Not available online | GPLv3+ | Sangoma |
| cdr | 15.0.17.26 | Enabled and up to date | GPLv3+ | Sangoma |
| cel | 15.0.15.17 | Enabled and up to date | GPLv3+ | Sangoma |
| certman | 15.0.49 | Enabled and up to date | AGPLv3+ | Sangoma |
| cidlookup | 15.0.25 | Enabled and up to date | GPLv3+ | Sangoma |
| cloudmigration | | Not Installed (Available online: 15.0.12) | Commercial | |
| conferences | 15.0.7.11 | Enabled and up to date | GPLv3+ | Sangoma |
| conferencespro | 15.0.3.18 | Newer than online version (15.0.3.16) | Commercial | Sangoma |
| configedit | 13.0.7.3 | Enabled and up to date | AGPLv3+ | Sangoma |
| contactimage | | Not Installed (Available online: 15.0.1) | Commercial | |
| contactmanager | 15.0.9.11 | Enabled and up to date | GPLv3+ | Sangoma |
| core | 15.0.22.20 | Enabled and up to date | GPLv3+ | Sangoma |
| cos | 15.0.15 | Enabled and up to date | Commercial | Sangoma |
| customappsreg | 15.0.14 | Enabled and up to date | GPLv3+ | Sangoma |
| customcontexts | 13.0.3.2 | Enabled and up to date | GPLv2+ | Sangoma |
| cxpanel | 15.0.4 | Enabled and up to date | GPLv3 | Sangoma |
| dahdiconfig | 15.0.5.8 | Enabled and up to date | GPLv3+ | Sangoma |
| dashboard | 15.0.15 | Enabled and up to date | AGPLv3+ | Sangoma |
| daynight | 15.0.12 | Enabled and up to date | GPLv3+ | Sangoma |
| dictate | 15.0.7 | Enabled and up to date | GPLv3+ | Sangoma |
| digium_phones | 15.0.12 | Enabled and up to date | GPLv2 | Sangoma |
| digiumaddoninstaller | 13.0.1.4 | Enabled and up to date | GPLv2 | Sangoma |
| directory | 15.0.18 | Enabled and up to date | GPLv3+ | Sangoma |
| disa | 15.0.4.9 | Enabled and up to date | AGPLv3+ | Sangoma |
| donotdisturb | 15.0.10 | Enabled and up to date | GPLv3+ | Sangoma |
| dynroute | | Not Installed (Available online: 15.0.3) | GPLv3+ | |
| endpoint | 15.0.39.55 | Enabled and up to date | Commercial | Sangoma |
| endpointman | 14.0.3 | Enabled; Not available online | GPLv3+ | Sangoma |
| extensionroutes | 15.0.8 | Enabled and up to date | Commercial | Sangoma |
| extensionsettings | 13.0.4 | Enabled and up to date | GPLv3+ | Sangoma |
| fax | 15.0.22 | Enabled and up to date | GPLv3+ | Sangoma |
| faxpro | 15.0.8.15 | Newer than online version (15.0.8.12) | Commercial | Sangoma |
| featurecodeadmin | 13.0.6.11 | Enabled and up to date | GPLv3+ | Sangoma |
| filestore | 15.0.4 | Enabled and up to date | AGPLv3 | Sangoma |
| findmefollow | 15.0.34 | Enabled and up to date | GPLv3+ | Sangoma |
| firewall | 15.0.42 | Enabled and up to date | AGPLv3+ | Sangoma |
| framework | 15.0.23.25 | Enabled and up to date | GPLv2+ | Sangoma |
| fw_langpacks | 14.0.1 | Enabled and up to date | GPLv3+ | Sangoma |
| hotelwakeup | 15.0.5.5 | Enabled and up to date | GPLv2 | Sangoma |
| iaxsettings | 15.0.8 | Enabled and up to date | AGPLv3 | Sangoma |
| infoservices | 15.0.3 | Enabled and up to date | GPLv2+ | Sangoma |
| iotserver | 15.0.7.2 | Enabled and up to date | Commercial | Sangoma |
| irc | 13.0.1 | Enabled and up to date | GPLv3+ | Sangoma |
| ivr | 15.0.30 | Enabled and up to date | GPLv3+ | Sangoma |
| languages | 15.0.12 | Enabled and up to date | GPLv3+ | Sangoma |
| logfiles | 15.0.15 | Enabled and up to date | GPLv3+ | Sangoma |
| manager | 15.0.17 | Enabled and up to date | GPLv2+ | Sangoma |
| miscapps | 15.0.10 | Enabled and up to date | GPLv3+ | Sangoma |
| miscdests | 15.0.2.12 | Enabled and up to date | GPLv3+ | Sangoma |
| music | 15.0.22 | Enabled and up to date | GPLv3+ | Sangoma |
| oracle_connector | 15.0.14 | Enabled and up to date | Commercial | Sangoma |
| outroutemsg | 15.0.9 | Enabled and up to date | GPLv3+ | Sangoma |
| paging | 15.0.4.33 | Enabled and up to date | GPLv3+ | Sangoma |
| pagingpro | 15.0.1.22 | Newer than online version (15.0.1.21) | Commercial | Sangoma |
| parking | 15.0.15.4 | Enabled and up to date | GPLv3+ | Sangoma |
| parkpro | 15.0.13 | Enabled and up to date | Commercial | Sangoma |
| pbdirectory | 2.11.0.6 | Enabled; Not available online | GPLv3+ | Sangoma |
| phonebook | 15.0.12 | Enabled and up to date | GPLv3+ | Sangoma |
| phpinfo | 13.0.2 | Enabled and up to date | GPLv2+ | Sangoma |
| pinsets | 15.0.1.15 | Enabled and up to date | GPLv3+ | Sangoma |
| pinsetspro | 15.0.4 | Enabled and up to date | Commercial | Sangoma |
| pm2 | 15.0.10 | Enabled and up to date | AGPLv3+ | Sangoma |
| pms | 15.0.5 | Enabled and up to date | Commercial | Sangoma |
| presencestate | 15.0.11 | Enabled and up to date | GPLv3+ | Sangoma |
| printextensions | 13.0.3.4 | Enabled and up to date | GPLv3+ | Sangoma |
| queueprio | 15.0.10 | Enabled and up to date | GPLv3+ | Sangoma |
| queues | 15.0.34 | Enabled and up to date | GPLv2+ | Sangoma |
| queuestats | 15.0.9 | Enabled and up to date | Commercial | Sangoma |
| qxact_reports | 15.0.12 | Enabled and up to date | Commercial | Sangoma |
| recording_report | 15.0.8 | Enabled and up to date | Commercial | Sangoma |
| recordings | 15.0.3.19 | Enabled and up to date | GPLv3+ | Sangoma |
| restapi | | Not Installed (Available online: 13.0.21.2) | AGPLv3 | |
| restapps | 15.0.37 | Disabled; Pending upgrade to 15.0.38.7 | Commercial | Sangoma |
| ringgroups | 15.0.11.17 | Enabled and up to date | GPLv3+ | Sangoma |
| sangomaconnect | | Not Installed (Available online: 15.0.55) | Commercial | |
| sangomacrm | 15.0.23.8 | Enabled and up to date | Commercial | Sangoma |
| sangomartapi | | Not Installed (Available online: 15.0.48.2) | Commercial | |
| setcid | 15.0.9 | Enabled and up to date | GPLv3+ | Sangoma |
| sipsettings | 15.0.11 | Enabled and up to date | AGPLv3+ | Sangoma |
| sipstation | 15.0.11 | Enabled and up to date | Commercial | Sangoma |
| sms | 15.0.36 | Enabled and up to date | Commercial | Sangoma |
| soundlang | 15.0.5.10 | Enabled and up to date | GPLv3+ | Sangoma |
| speeddial | 2.11.0.4 | Enabled; Not available online | GPLv3+ | Sangoma |
| superfecta | 15.0.3 | Enabled and up to date | GPLv2+ | Sangoma |
| sysadmin | 15.0.29.12 | Enabled and up to date | Commercial | Sangoma |
| timeconditions | 15.0.15.11 | Enabled and up to date | GPLv3+ | Sangoma |
| tts | 15.0.12 | Enabled and up to date | GPLv3+ | Sangoma |
| ttsengines | 15.0.4.7 | Enabled and up to date | AGPLv3 | Sangoma |
| ucp | 15.0.14.5 | Enabled and up to date | AGPLv3+ | Sangoma |
| userman | 15.0.69.7 | Enabled and up to date | AGPLv3+ | Sangoma |
| vega | 15.0.12 | Enabled and up to date | Commercial+ | Sangoma |
| versionupgrade | | Not Installed (Available online: 15.0.39) | Commercial | |
| vmblast | 15.0.11.8 | Enabled and up to date | GPLv3+ | Sangoma |
| vmnotify | 15.0.14 | Enabled and up to date | Commercial | Sangoma |
| voicemail | 15.0.27 | Enabled and up to date | GPLv3+ | Sangoma |
| voicemail_report | 15.0.7 | Enabled and up to date | Commercial | Sangoma |
| voipinnovations | 15.0.25 | Enabled and up to date | Commercial | Sangoma |
| vqplus | 15.0.7.30 | Enabled and up to date | Commercial | Sangoma |
| weakpasswords | 13.0.2 | Enabled and up to date | GPLv3+ | Sangoma |
| webcallback | 15.0.6.3 | Enabled and up to date | Commercial | Sangoma |
| webrtc | 15.0.10.9 | Enabled and up to date | GPLv3+ | Sangoma |
| xmpp | 15.0.6.9 | Newer than online version (15.0.6.8) | AGPLv3 | Sangoma |
| zulu | 15.0.62 | Enabled and up to date | Commercial | Sangoma |
±---------------------±-----------±--------------------------------------------±------------±----------+

Is endpoint up to date? Including paying for the additional support items required to keep it up to date?

From the console output up above, it says that endpoint is up to date but it’s not seeing the new version. I paid for the 25 year license of all the commercial modules.

I seem to remember references to needing to install the edge version, although I can’t find the thread, at the moment.

So paying for that license doesn’t give 25 years of updates? I know it doesn’t provide support but I thought for sure it’d receive updates. Also, their platform is awful enough that it’ll allow a module that is free to update to proceed even though it breaks dependencies?

I’m having the same issue. i have endpoint manager 15.0.24.12, and it will not find/update to 15.0.52.6. I’m not a tech guy (nurse) and find this very confusing/frustrating; therefore, any simple steps would be appreciated.

I found this forum post from a few years ago /t/phone-apps-restapps-upgrade-fails-due-to-unavailable-endpoint-manager-version/58911 that indicates that freepbx is very dishonest in their business model. They charge extra for their 25 year license but they don’t actually give you updates past the first year. They do allow dependencies to crash as a result of the lack of renewing. Extremely dishonest and making me highly regret the money I paid for my, and many of my client’s, licenses. I successfully rolled back restapps to a working version using fwconsole ma downloadinstall restapps --tag 15.0.38.3 and turned off module updates.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.