FreePBX | Register | Issues | Wiki | Portal | Support

Restapps not running and I can't start it


(Avayax) #1

Failed to run: ‘runuser -l asterisk -c ‘cd /drbd/httpd/www/html/admin/modules/restapps/node && mkdir -p /var/lib/asterisk/restapps && mkdir -p /drbd/httpd/www/html/admin/modules/restapps/node/logs && export HOME="/home/asterisk" && echo “prefix = ~/.node” > ~/.npmrc && export FOREVER_ROOT="/var/lib/asterisk/restapps" && export ASTLOGDIR="/var/log/asterisk" && export PATH="$HOME/.node/bin:$PATH" && export NODE_PATH="$HOME/.node/lib/node_modules:$NODE_PATH" && export MANPATH="$HOME/.node/share/man:$MANPATH" && npm start’’[root@freepbx-b log]#

Running FreePBX Distro HA


(Andrew Nagy) #2

Did you even attempt to the the command it couldnt run?


(Avayax) #3

Yes. I ran:
[root@freepbx-b asterisk]# fwconsole restart restapps
Running FreePBX shutdown…

RestApps Server is not running

Running FreePBX startup…
Unable to run Pre-Asterisk hooks, because Asterisk is already running on PID 131321 and has been running for 12 hours, 35 minutes, 48 seconds
Starting RestApps Server…
[--------------->------------] 10 secs
Failed to run: ‘runuser -l asterisk -c ‘cd /drbd/httpd/www/html/admin/modules/restapps/node && mkdir -p /var/lib/asterisk/restapps && mkdir -p /drbd/httpd/www/html/admin/modules/restapps/node/logs && export HOME="/home/asterisk" && echo “prefix = ~/.node” > ~/.npmrc && export FOREVER_ROOT="/var/lib/asterisk/restapps" && export ASTLOGDIR="/var/log/asterisk" && export PATH="$HOME/.node/bin:$PATH" && export NODE_PATH="$HOME/.node/lib/node_modules:$NODE_PATH" && export MANPATH="$HOME/.node/share/man:$MANPATH" && npm start’’[


(Andrew Nagy) #4

Please run the command it was unable to run


(Cory Cook) #5

Did you ever find a solution to this? I’m currently facing the same situation… :frowning:


(Andrew Nagy) #6

This thread is two years old. No you aren’t.


(Andrew Nagy) #7