REST Apps on Aastra57i missing hostname in URL

I have a group of about 150 Aastra 6757i phones to configure, and I have the System Builder bundle with the REST Apps and Endpoint Manager. When I configure the softkeys for REST Apps, I get the following output in the cofnig file in /tftpboot:

softkey1 type: "xml"
softkey1 label: "DND"
softkey1 value: "http://:84/applications.php/donotdisturb/main?user=2304"
softkey1 line: "1"
softkey1 states: "idle connected incoming outgoing busy "
softkey2 type: "xml"
softkey2 label: "Call Forward"
softkey2 value: "http://:84/applications.php/callforward/main?user=2304"
softkey2 line: "1"
softkey2 states: "idle connected incoming outgoing busy "
softkey3 type: "xml"
softkey3 label: "Voicemail"
softkey3 value: "http://:84/applications.php/voicemail/main?linestate=$$LINESTATE$$&user=2304"
softkey3 line: "1"
softkey3 states: "idle connected incoming outgoing busy "

As you can see, it’s completely missing the machine form the URL in softkey? value:

Have I missed setting something up somewhere, or does this need to be submitted as a bug?

Thanks for the sanity check!

Settings, Endpoint Manager, Global Settings allows you to set your internal and external hosts. Then when creating the template(s), you choose which of these you wan to use.

Ah, sorry, should have thought to mention that those are filled out, and even present elsewhere in the generated config file. As demonstrated here in the same file:

firmware server: "tftp://10.100.0.10/aastra/1"
sip xml notify event: "1"
action uri registered: "http://10.100.0.10:84/sync.php?user=2304"
services script: "http://10.100.0.10:84/applications.php/restapps/main?user=2304"
xml application URI: "http://10.100.0.10:84/applications.php/restapps/main?user=2304"

So it’s getting those values, but not putting them in the URI for the softkeys.

When I manually edit the config file and reboot, those buttons seem to work.

Solved by replacing

internal
with the actual address of the server in the template. I think there may be a bug with that default syntax.

Open a bug report at http://issues.freepbx.org and include the phone make and model in the report.