Rest Apps, BLF, and Asterisk 13 Compatibility?

Continuing the discussion from Parking and Conference BLF Lights On when Parking Lot and Conference room empty:

Like Bryan, I am having a problem with FreePBX Rest Applications working properly with Asterisk 13. As an example, when phones first boot, the BLF for the Parking App is off. When the first call is parked, the BLF turns on. After the call is retrieved from Parking however, the BLF does not turn off. As another example, the DND Rest Application BLF does not work at all. The BLF never turns on, regardless of whether I have DND enabled through the DND Rest App.

In contrast, the Follow Me Rest App does work. The BLF turns on when enabled through the Rest App, and turns off when disabled through the Rest App.

BLF’s for extensions seem to work fine. I only notice this with the Rest Applications. I have poured through the settings in FreePBX 13, and read as much as I could in the wiki to find any reference or resolution to my problem. But, so far, nothing has worked. Does anyone have any suggestions as to what the problem is? Or is this a problem with Asterisk 13 and the Rest Applications?

To make matters worse, I uninstalled the REST API module and the REST Applications module in Module Admin to try to reset things. When trying to reinstall, I get:

UID was not numeric.

Thanks for any help.

Apprently, the REST API module does not like it when the “Login Name” in User Management is anything but a number. I had created some users with a login name using their actual name, not extension number, and that is where the installation of the REST API module was failing. Would this be a bug? If so, I will be glad to create a ticket at

However, I am still having issues with the REST APPS and BLF on the phones. After reinstalling the REST API and REST Applications modules, it has improved, but not quite right. For example, now the DND Rest App works correctly with the BLF key. But, I am still having issues with the Conference REST App and the Parking REST App. The Conference BLF is always on, and the Parking BLF works sometimes, but will stop working. Very strange…

I meant to include system details on my first post, but here is what I am running:

  • FreePBX Distro 10.13.66-6
  • Asterisk 13.5.0
  • Phones: Yealink T48g, Yealink T46g, and Aastra 6737i

Works fine for us on our corporate system

OK. I thought since the circumstance was a little unconventional, it could be causing problems. Typically when the system is installed there are no users setup in User Management, so it would have been unlikely to happen often. Since I had removed the modules, then tried to reinstall them after already having some users setup in User Management with names, not numbers, that it may have thrown a wrinkle in the normal process.

Out of curiosity, do the REST Apps (Parking in particular) properly light BLF keys? For what it’s worth, I am running chan_sip on port 5060 and pjsip on 5061. (I believe this was the default when we originally installed FreePBX Distro 6.12.65). Thanks.

I’m curious, does anyone have all three of these working together properly?

  • Asterisk 13
  • Rest Apps
  • Parking BLF

Thanks for confirming positive or negative. I just can’t seem to figure anything out on this.


I’m just starting to play with REST Apps on my T46G, I will be watching this closely, as several other threads dealing with PJSIP, and the other on one way audio.

Question, which firmware are you using on your Yealink phones?

I’m using the .70 firmware from Yealink’s site vs. the .60 that Endpoint manager will install.

This was working for me, but recently it stopped. Parking button will park a call, but not beep or display on the other phones.

restarting the rest daemon fixed this for me.


You might have to get used to it for a bit. I have to do this daily or I lose BLF hints for all rest apps such as DND, Follow Me, Park, etc on yealink t28. Have not gotten around to collecting all the details/logs and submitting a bug report though. Can’t imagine this isn’t happening to more folks though.

Asterisk 11.19.0
Fpbx gui 13.0.46
Pbx firmware 6.12.65-31

I have the same issue with the parking BLF and RESTAPPS using yealink 46G and the most recent version of FreePBX 6.12.65-31. All modules are up to date. Once a call is parked the light will stay lit. This seems to only be an issue when using asterisk 13. I also get a notification that Parking is Enabled on the screen?. Asterisk 11 works fine with the RESTAPPS parking BLF. There seem to be multiple bug reports related to this:

Youn should be aware there is a bug in Asterisk dealing with broken BLFs.

It’s fixed in 11.21 and 13.7.

Good news! Any idea if the endpoint de-registration issue is fixed in 11.21 from 11.20?

So, will this be fixed then with a FreePBX update? I too am having the issue with strange BLF behavior…

So now running asterisk 13.7 and still having the same issue…Once a call is parked the BLF light will stay lit. This seems to only be an issue when using asterisk 13. I also get a notification that Parking is Enabled on the screen?. Asterisk 11 works fine with the RESTAPPS parking BLF. I will create a bug report if not already done.

Yes create a bug report but ResApps are known to have issues on Asterisk 13 and also PJSIP. Asterisk changed a ton in the AMI and most apps have to be changed to handle it. We have done them as they are reported to us.

Anyone know if a bug was opened on this?


FWIW - My BLF issues seem to be resolved with the 10.13.66-7 update. It did in fact install Asterisk 13.7 and the Parking, Follow Me, etc BLF’s work properly now. I do have to say I am running on chan_sip, not chan_pjsip.

1 Like

Ok…So rebooted and yes… my Parking BLF issues also seem to be resolved on Asterisk 13 :slight_smile:

1 Like

This is great news all! Please let us know if you experience any other issues!

This issue has returned for me in asterisk 13.11.2 up to 13.12.xx. Parking BLF stays on all the time even when no calls are parked. With asterisk 11, the same behavior, but on a yealink t28 (at least) it flashes when a call is parked. Not sure if this was an intention behavior change or no.