RESOLVED: Module Update "Whaa" Problem

I’ve just run a couple of module updates this morning and it seems to have made some strange changes to the web interface. In the top left, the letters Whaa appear on all of the admin pages, the System Status page will not load and the fonts on the CDR page has been increased.

Not sure what’s going on!

Same here, tried updating and changing asterisk version but nothing solved the problem. Restarting the server makes asterisk unusable.

When trying amportal chown, this error comes up:

[[email protected] ~]# amportal chown

Fetching FreePBX settings with gen_amp_conf.php…
/usr/local/sbin/amportal: line 52: Whaa: command not found

/var/lib/asterisk/bin/freepbx_engine: line 100: Whaa: command not found
**** WARNING: ERROR IN CONFIGURATION ****
astrundir in ‘/etc/asterisk’ is set to but the directory
does not exists. Attempting to create it with: 'mkdir -p ’

mkdir: missing operand
Try `mkdir --help’ for more information.
**** ERROR: COULD NOT CREATE ****
Attempt to execute 'mkdir -p ’ failed with an exit code of 1
You must create this directory and the try again.

Any help at the moment is greatly appreciated.

Also the same problem here since installing the following updates this morning:

CallerID Lookup 2.11.1.12
System Admin 12.0.28.3

We are using FreePBX 12.0.62.

Well at least I’m not the only one! Better make sure I don’t reboot the server then!

If you ever happen to reboot the server accidentally, just log in via ssh and run

/usr/sbin/asterisk -f

This will force asterisk to run with the hardcoded config files, rather than amportal, and you will still have a functioning pbx. I’m running it like this for the moment and waiting for an expert to come and help us :frowning:

And this “Whaa” thing appears on everywhere, and there is no information on the net about it. For example at the end of the loading section of asterisk:

[2015-05-06 12:17:05] ERROR[2330]: chan_unistim.c:6604 reload_config: Unable to load config unistim.conf
[2015-05-06 12:17:05] ERROR[2330]: res_clialiases.c:193 load_config: res_clialiases configuration file ‘cli_aliases.conf’ not found
Whaa
Whaa

Any ideas?

How long have you had the issue for? This only started happening to me this morning when I updated the modules.

Seeing as there’s a few people here and another thread which seems to be related, I’ve posted a Bug on the Tracker:
http://issues.freepbx.org/browse/FREEPBX-9210

Yes same here, after doing the latest updates the problem occured on two of our servers this morning. I’m not updating the others :smile:

Me either, unfortunately I probably did the updates on the worst possible server first!

Same here, last updates broke: running “asterisk only” as suggested

You can try rolling back the System Admin module which has been mentioned in other threads, that seems to have worked for me but I daren’t reboot the system as mine is a production server.

Add me to the list of user with the issue. “Whaa” indeed!

If you still can access your Module Admin (haven’t rebooted), go to the sysadmin module there and roll it back to 12.0.28.2, this helped me (but, I have NOT rebooted it)

I can confirm that the solution is to rollback Sys Admin module to the previous version. Thanks for the help.

Hi,
I just updated 2 modules (cidlookup and systemadmin) and now all of a sudden the main page [myserver]/admin/config.php shows ‘Whaa’ text at the top of the page. (as do ALL the FreePBX GUI pages too) I can log on and log off, it makes no difference - the System Status page does not finish loading any more…

(btw the update process did not finish properly, there was a timeout message some time after pressing ‘Apply Config’ - but alas it seems I can access other settings/modules and phones are still working)

FreePBX 12.0.62
PBX Firmware:5.211.65-12
PBX Service Pack:1.0.0.0

There are already a few threads about this but we’ve also posted a Bug to the Tracker here: http://issues.freepbx.org/browse/FREEPBX-9210

Whatever you do, don’t reboot!

And in case if you do reboot, you can temporarily run asterisk from cli with

/usr/sbin/asterisk -f

Looks like rollback of System Admin back to 12.0.28.2 did the trick (GUI is usable again and System Status page also works again) (online version is 12.0.28.3)

How did you manage to roll it back?

EDIT: Never mind, found it!

Can someone point this to the Issue Tracker, I am not registered there…

My remedy (at least I hope it helps): rollback the System Admin to 12.0.28.2 vs the online version 12.0.28.3.
(I did not try rebooting after this, mine is a production system :stuck_out_tongue_winking_eye: )