[RESOLVED]Incoming Call Issue

Hi,

I cannot receive incoming calls. I have DAHDI. I have setup inbound route and is currently pointing to an extension. But when I initiate an incoming call, all it says this number is not in service. Here is the log…

Any help is greatly appreciated.

Thanks,
Deepak


– Starting simple switch on ‘DAHDI/1-1’
– Executing [[email protected]:1] Set(“DAHDI/1-1”, “__FROM_DID=8885493088”) in new stack
– Executing [[email protected]:2] NoOp(“DAHDI/1-1”, “Received an unknown call with DID set to 8885493088”) in new stack
– Executing [[email protected]:3] Goto(“DAHDI/1-1”, “s,a2”) in new stack
– Goto (from-pstn,s,2)
– Executing [[email protected]:2] Answer(“DAHDI/1-1”, “”) in new stack
– Executing [[email protected]:3] Wait(“DAHDI/1-1”, “2”) in new stack
– Executing [[email protected]:4] Playback(“DAHDI/1-1”, “ss-noservice”) in new stack
– <DAHDI/1-1> Playing ‘ss-noservice.ulaw’ (language ‘en’)
== Spawn extension (from-pstn, s, 4) exited non-zero on ‘DAHDI/1-1’
– Executing [[email protected]:1] Macro(“DAHDI/1-1”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/1-1”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“DAHDI/1-1”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“DAHDI/1-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“DAHDI/1-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘DAHDI/1-1’ in macro ‘hangupcall’
== Spawn extension (from-pstn, h, 1) exited non-zero on ‘DAHDI/1-1’
– Hungup ‘DAHDI/1-1’

It’s not hitting the inbound route because you have the CID number filled in:

Caller ID Number: 888XXXXXXX

That limits the route to callers with caller ID number 888XXXXXXX. Is that what you want?

That helped. I removed the CID and now it is accepting calls from any number. Thanks alot.

Description: In_TollFree
DID Number: 888XXXXXXX
Caller ID Number: 888XXXXXXX
CID Priority Route: not checked
Alert Info:
CID name prefix: InDAHDI
Music On Hold: Default
Signal RINGING: checked
Pause Before Answer: disabled
Privacy Manager: No
Set Destination
Extensions => 1114

And in the DAHDi section, the context is “from-pstn”.

I actually was using Visual Dial Plan and the incoming was working fine then. But I had to uninstall it and now I want to use FreePBX(only) for all my configuration, dial plans etc. Visual Dial Plan created a extensions_vdp.conf file and the added 2 context viz. vdp_inbound and vdp_outbound in extension_custom.conf. I had to comment these because when I removed VDP, it removed extensions_vdp.conf file but did not comment those two contexts.

I guess the issue is with the context but not sure which. If you need more information, please feel free to ask.

What does your inbound route look like?