RESOLVED: How do I apply a patch to Asterisk on FreePBX distro?

I am able to create a conference bridge. That piece works fine. I am not able to get the process of, place call A, after connect press conference button, place call B, then press conference button to join. This piece fails. I get an error that says “Unable to complete conference” As for the video part, I was referencing this site lists.digium.com/pipermail/asterisk-video/2011-October/003560.html but the patch needed might not be included in your fix.

Thanks again for the follow up. I thought there might be some light shed in the sample configs

Thanks for posting this…

so I tried to download and follow your instructions … however I now get a red box at the top of the GUi saying “CANNOT CONNECT TO ASTERISK”

how do i fix this?

Hey, I tried to edit my original post but it won’t let me. At the time when I wrote it, freepbx 10.13.66-15 used asterisk 13.10 and I thought specific freepbx versions were tied to specific asterisk versions. That’s not the case, and by upgrading to 10.13.66-15 you will have upgraded to the latest asterisk version at that time in the process. That means that you are running asterisk13-core at version 13.10 but all the other asterisk components are a different version. The steps above should be:

fwconsole stop
yum downgrade asterisk13*-13.10.0-*
rpm -Fvh --nodeps asterisk13-core-13.10.0-2.shmz6.x86_64.rpm --force
fwconsole start

you should also do

nano /etc/yum.conf

and add the line:

exclude=asterisk1*

This will allow you up keep freepbx up to date without asterisk upgrading

Tried to do all the above. A new version of this “rpm -Uvh mISDNuser*.rpm” can’t find. Would like to apply Cisco patch to my Freepbx testing box. Yes I will apply in working environment if it works.

Any help would be cool!

Asterisk = 13.12.1
FreePBX 13.0.190.7

Cisco 8841
11-5-1 firmware

HI

I recently updated FreePBX to 10.13.66-16 and now the patch appears to have stopped working. Is there a way i can apply it to this version or do I have to go back to the old version?

I too cannot find mISDNuser-devel… I might try editing the spec file and removing the mISDNuser requirement to see if asterisk builds (do i really need mISDN?)

Oh yes, i am trying to patch for cisco phones too.

CIsco SIP-converted phones or Cisco SCCP phones?

Chan_SCCP_B works just fine for the latter. Been doing it for years.

These are the new lines

wget http://download.opensuse.org/tumbleweed/repo/src-oss/suse/src/mISDNuser-2.0.19-1.7.src.rpm
rpm --nomd5 -ivh mISDNuser-2.0.19-1.7.src.rpm

By the way… after we install your patch, are also all the “make samples” files filled?

Marco

Are there updated patch instructions for the new FreePBX V14.0.1.1 running Asterisk V13.16.0? I have also noticed on the yum1.freepbxdistro site there isn’t a SRPM for asterisk13-13.16.0-1 yet.

Have same problem Mark … couldn’t find it at all, latest was the 13.14 src rpm

can we use the src file from asterisk directly and not the rpm?

Any help would be highly appreciated

1 Like

Is there any way to verify that the patch was applied correctly?

I tried this as you suggested

No source RPM found for asterisk13-13.22.0-1.sng7.x86_64
No source RPM found for asterisk13-13.19.1-1.sng7.x86_64
No source RPM found for asterisk13-13.21.1-1.sng7.x86_64

No source RPM found for asterisk14-14.7.5-1.sng7.x86_64
No source RPM found for asterisk14-14.7.3-1.sng7.x86_64
No source RPM found for asterisk14-14.7.4-1.sng7.x86_64

Did an install just to test this , no luck

Please document the full command you ran as I just tested this last week and documented it in our wiki

Just as you posted here and with variants

yumdownloader --source asterisk14-14.6.0

yumdownloader --source asterisk14-*

yumdownloader --source asterisk13-13*

yumdownloader --source asterisk13-13.19.1

and many other variantas.

using the wildcard it showed me versions above with no installation source

This was from a new install of SNG7

edit ----looks like I found on another thread that I need to install sangoma-devel Idid not see that here

OK, to sum up, these three command will work for me:

[[email protected] ~]# yum install sangoma-devel
[[email protected] ~]# yumdownloader --source asterisk14-14.6.0
[[email protected] ~]# ls *.src.rpm

You warned that the first command is for testing instead of production. Can you give me more detail? Does that mean I cannot use the server in production enviroment because it’s unstable?

After successfully running these three command without showing errors, did I successfully patch the Cisco firmware the original post mentioned?

Thanks a lot!

I’m not a Sangoma employee, but as far as I understand, patches and updates only end up is the stable repo once it was tested and confirmed there isn’t any issues.

So if you use the other repo, it does not necessarily mean that using that repo will break things… But it’s not recommended to use in a production environment because there’s no QA tag on it. :wink:

1 Like

I see. thank you. Nothing is guaranteed. I will test it first before I put it in production.

I realize this is an old thread, but I just wanted to let everyone know that I created a wiki page on FreePBX on how to patch FreePBX 16 and Asterisk 16 with the usecallmanager.nz Presence for Cisco SIP-Firmware Phones:

Patching Asterisk 16 on FreePBX 16 with USECALLMANAGER.NZ Presence for Cisco SIP-Firmware Phones

I hope this helps

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.