Resolved - Changing asterisk manager password - users/devices are greyed out?

Hi Everyone,

I am running into a weird issue with my FreePBX installation.
I have FreePBX version, and I’ve been trying to change the asterisk manager password from the default of amp111.

I’ve changed the /etc/asterisk/manager.conf + /etc/amportal.conf files to reflect the new password. Also, the new password does not feature any symbols in it, just an alphanumeric password.

Once I change the two config files, I issue an ‘amportal restart’, and FreePBX complains that Asterisk if ‘offline’, and my devices/users become greyed out in the GUI itself.

If I change the two config files back to the default manager password, FreePBX comes back up all ok and happy.

Any ideas on why this occurs? Is there a third area this password needs to be changed?

Any help would be greatly appreciated, thanks!



I resolved the issue by doing some more research, turns out in ‘Advanced Settings’, I needed to turn on ‘Override Read only Settings’. Once doing this, I was able to change the password from the GUI.

Also, make sure the password has been changed on the two config files as well.