Reset Queue Stats

We are using iSymphony with the Queue license and want to have the Queue stats to reset every night.

I found the option inside the FreePBX GUI but it does not seem to reset like it should.

Can anyone point me in the direction on how to resolve this?

Setup:
PBX Firmware: 4.211.64-4
iSymphony: v2.8.1 rev 4840
Queue:
Add to iSymphone=Checked
Reset Queue Stats: Run=Daily, Randomize=unchecked

Let me know if you require any more information.

Thank you
Brett

Settings that should work.

What does

crontab -l -u asterisk show

Thank you for your response.

[[email protected] ~]# crontab -l -u asterisk
46 * * * * /var/lib/asterisk/bin/freepbx-cron-scheduler.php
*/5 * * * * php /var/www/html/admin/modules/qxact_reports/import_queue_data.php 2>&1 >/dev/null
0 0 1 * * php /var/lib/asterisk/agi-bin/backuprecordings.php 2>&1 >/dev/null
*/60 * * * * /var/lib/asterisk/bin/storage.php
11 2 * * * php /var/lib/asterisk/agi-bin/abnormal.php 2>&1 >/dev/null
@daily /var/lib/asterisk/bin/queue_reset_stats.php --id=650
@daily /var/lib/asterisk/bin/queue_reset_stats.php --id=651
37 12 * * * php /var/lib/asterisk/agi-bin/update_license.php 2>&1 >/dev/null

I see the two Queues listed there (650 and 651)

Well that is correct. Those commands will reset the queue stats. Is iSymphony not picking up the queue stats have been reset.

What does asterisk -rx “queue show 651” return

[[email protected] ~]# asterisk -rx “queue show 651” return
651 has 0 calls (max unlimited) in ‘leastrecent’ strategy (41s holdtime, 179s talktime), W:0, C:108, A:24, SL:81.5% within 60s
Members:
User(Local/[email protected]/n from SIP/202) (ringinuse enabled) (dynamic) (Not in use) has taken 8 calls (last was 413 secs ago)
No Callers

I am not 100% sure I am reading it correctly but it looks like it has not reset. C=108 and base on their call volume I do not think they would have received 108 calls with in the last 10 hours.

Tony,

Do you have any other suggestions why this is not working as t should?

I suggest opening a bug report

Will do thank you.

Just as an update the permissions where screwed up. Running amportal chown fixed my issue. Thank you Tony for you assistance.