Res_pjsip_registrar.c: AOR 'XXX' has no configured max_contacts

Hello, i have a ‘problem’ with my trunk.
I just installed FreePBX 16.0.28. and configure trunk for use with my patton.
I specifically set:

But in Aterisk log I have this warning every 10 seconds!!!

WARNING[6468] res_pjsip_registrar.c: AOR ‘patton’ has no configured max_contacts. Endpoint ‘patton’ (mypattonip:5060) unable to register

If I change registration to send (or receive), submit change, apply, and then change again to ‘none’ error disappears for an hour.

On pjsip.aor.conf (auto generate from FreePBX) I have:
[patton]
type=aor
qualify_frequency=60
contact=sip:[email protected]:5060

You configured the the Patton to register with you, which you shouldn’t need to do if you know its address.

Thanks David55
My patton has an old configuration that worked even with an old version of asterisk
I don’t know much about how patton works and I wouldn’t want to change (if possible) the configuration
It is possible to solve the problem on freepbx, for example by adding the value max_contacts?
maybe in the file pjsip.aor_custom.conf?

You would need to change Registration to Receive and Server to dynamic. I’ve no idea what it is doing with authentication, but with the current setting you won’t challenge it for authentication, so if you are happy with its not authenticating itself, you could probably leave that.

I probably fixed it without changing the patton configuration
In the file pjsip.aor_custom_post.conf I added
patton
max_contacts=1

Everything seems to work fine… at the moment :slight_smile:
THANK YOU

That’s a non-standard configuration. I assume it will behave as long as the registration is for the same address as the server setting, but, if they diverge, it may not be clear which one is actually used.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.