Res_fax_custom_conf not working


(Cc Mha) #1

my res_fax.conf looks like this (automatically filled):

[general]
#include res_fax_custom.conf
minrate=9600
maxrate=14400

my res_fax_custom.conf looks like this:
[general]
maxrate=33600
minrate=2400

Whatever I do, “fax show settings” only give me the values of “res_fax_conf” and never my “custom”-ones. Doesn’t matter when I reload the core with “core reload” - before or after saving the changes a.k.a. “pushing the button”.

What am I missing? --> also the “fax_digium”-settings can’t be changed (ecm off for example --> it’s always on)

Do I have to change some main settings so that the “custom”-ones aren’t ignored any longer?


(Lorne Gaetz) #2

Max and min transfer rates are settable in the GUI, Settings -> Fax Configuration


(Cc Mha) #3

In my installation I can only choose between these values in the GUI (both min and max):

9600
12000
14400


(Lorne Gaetz) #4

Just tested and there is no supported way to override the settings written by FreePBX by using the custom file. If you look at res_fax.conf, you will see the include comes after the opening of the general section but before the other settings. So to use res_fax_custom.conf correctly, you would not add the [general] line, that exists already, you just add your parameters.

Unfortunately, for any parameters that appear in both the custom file and res_fax conf file, the one to be read last governs. What the fax module needs at the moment is:

  • GUI rate params expanded to include all acceptable values, not just the three provided
  • a new file called res_fax_custom_post.conf and a new include line at the end of res_fax for it.

You can open a feature request for this, but we’re not likely to assign a high priority. As an OSS module, ideally someone from the community will contribute these features.


(Cc Mha) #5

OK. thanks. As a paying customer of the FaxPro-module I am disappointed now, but that seems to be the only way.

Changing the lines in
/var/www/html/admin/modules/fax/views/form.php
from:
‘9600’ => ‘9600’,
‘12000’ => ‘12000’,
‘14400’ => ‘14400’

to

                 	'4800' => '4800',
                    '9600'  => '9600',
                    '12000' => '12000',
                    '14400' => '14400',
                    '28800' => '28800',
                    '33600' => '33600' 

seems to do the trick, once. Maybe someone will find the time to add the missing values.