Request Timeout When Registering

Hi,

I am a newbie about general SIP and PBX so please bear with me. I tried searching before asking this question but couldn’t solve my problem even if I found several answers.

My question is I’m trying to setup FreePBX on a DigitalOcean droplet. I successfully installed and can login to admin GUI. Problem is I don’t know how to login using an android client like Zoiper or CsipSimple. What should be the username, password and hostname? I tried host with droplet public ip address:5060 but android application still somehow gives timeout error. I hope someone can help me about this issue.

Thanks

Username is your extension, password is your extension’s password. Hostname in Zoiper is as you say. PublicIP:Port (In others like CSip the port is entered separately). Now the port is normally 5060 if you setup your extension using PJSIP, or 5160 (sometimes 5061) if you set it up using Chansip. Freepbx usually says “This device uses PJSIP technology listening on Port 5060 (UDP)” in the general tab of a particular extension. Except - If you are using IAX it doesnt though but you can goto the Extension and click on the “Advanced” tab and look for “port”. Normally 4569 if you used IAX.

You may also want to check your firewall. Start with wifi where hopefully your phone’s IP address is the same as the computer you are using to log onto Freepbx is one way to rule that out.
Cheers
Chris

Chris,

Thanks for your reply. I had already suspected it was a firewall issue as you said and tried disabling firewall but still no luck. I hope these outputs will be useful:

[[email protected] freepbx]# nmap -v -sV localhost -p 5060
Starting Nmap 6.40 ( http://nmap.org ) at 2017-05-08 19:52 UTC
NSE: Loaded 23 scripts for scanning.
Initiating SYN Stealth Scan at 19:52
Scanning localhost (127.0.0.1) [1 port]
Completed SYN Stealth Scan at 19:52, 0.02s elapsed (1 total ports)
Initiating Service scan at 19:52
NSE: Script scanning 127.0.0.1.
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00019s latency).
Other addresses for localhost (not scanned): 127.0.0.1
rDNS record for 127.0.0.1: centos7
PORT STATE SERVICE VERSION
5060/tcp closed sip

[[email protected] freepbx]# iptables -L -n
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:5060
ACCEPT udp – 0.0.0.0/0 0.0.0.0/0 state NEW udp dpt:5060

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Firewalld is disabled and stopped. OS is CentOS7.

Thanks.