Reports - no calls in your selection


This may not be the appropiate list, but I have found the following. This may be fixed in a development version. If so please tell me where to put it.

I am running Freepbx 2.1beta2 (Suse linux 10.0, php 5.04)

I have found after some debugging that the reason the compare calls and such under reports did not work, is that the session variables where not being set properly.

in the code their are still quite a few HTTP_SESSION_VARS being used. The AMP_SQL variable was not being set, this caused the sql to have NeverReturnAnything added to the end. This meant that other than the Call logs under reports none of them worked. I changed



call-comp.php:$AMP_CLAUSE = $_SESSION[‘AMP_SQL’];

And that fixed it.

There are also some path issues


should be


The list below would also be affected.

aps-hst1:/var/www/htdocs/admin/cdr # grep AMP_SQL *
call-daily-load.php:$AMP_CLAUSE = $HTTP_SESSION_VARS[‘AMP_SQL’];
call-last-month.php:$AMP_CLAUSE = $HTTP_SESSION_VARS[‘AMP_SQL’];
graph_hourdetail.php:$AMP_CLAUSE = $HTTP_SESSION_VARS[‘AMP_SQL’];
graph_statbar.php:$AMP_CLAUSE = $HTTP_SESSION_VARS[‘AMP_SQL’];



After maaaaaany hours I have figured out the following solution and combinations.

It turns out that it is not directly related to E&M Wink, although it is definetly made worse by how the phone company implements the T1, as I have this working elsewhere without the same problems.

In the dialing options under general. I removed the “r” option. I removed both but, it is possible that only the outgoing one is required.

This did not actually fix the problem until i changed a couple of other settings. (I got this information from the asterisk forum)

So I also had to remove

Call Progress
Busy Detection

If you use busy detection you must also supply a pattern, or it will hangup on calls randomly (Or so it seems)

So this fixed (I hope completely)

Not being able to dial into the local goverments voicemail.
1-800 dialing problems.
Not detecting the messages from the phone company (ie “this number is not in service”)
Random hangups
Busy tones when the number is not in use
4 or 5 rings and then getting a busy tone.
other random call issues

These errors all originaly pointed at answer supervision problems, (which their are issues with in that area “Northern Canada”) but no amount of driver changes or even hardware type changes would fix it.

This problem also showed up on an fxo line when I configured it.

And then I had to restart asterisk for it to take effect.

I hope this helps somebody.