Replace NIC

i am having some issues with dropped calls and some crackel on the calls. I think it is the NIC i am using. I put a new NIC in the system and it see it on ETH1. i gave it an IP and a subnet. rebooted the system and told it to auto start. it gets a link light and the dashboard sees it along with the admin panel but i cannot ping it. How do i swap over to this new NIC and make sure it is working first?

Is your first nic (eth0) still active?
I would make sure that eth0 is inactive

ifdown eth0

… and make sure that you have a gateway set for eth1.
You can only have one default gateway.

Additionally, if you’re running any firewall it may be unaware of the new nic. Try disabling your firewall and see if you can ping it then (after the gateway, netmask, and IP are set on eth1)

yes it is still active

eth0 = gateway
eth1 = gateway

when i putty into the server i can ping either one

from outside my workstation i can only ping eth0

i disabled the freepbx firewall and still could not ping ETH1

if i take eth0 down will eth1 take over?

It depends on how your system is configured.

In the most theoretical case: yes, that’s how it should work. In a practical sense, though, it may not.

If you disable eth0, eth1 should be picked up as the new eth0, but that’s dependent on configuration details you haven’t provided, so there’s no way for us to really be able to answer your questions.

These aren’t PBX questions - these are straight Linux networking questions, and really basic ones. You probably need to find a good “Networking for Linux” book and read through that quick.

i tried it. LINUX side yes it worked perfectly. freePBX side not so much.
i could get to the dashboard but that was it. All the extensions went down and nothing was working.
went tot he admin panel and it wanted to activate. Dashboard was shoing traffic but all extensions down.

Your extensions are registered to a specific IP address, so if you disable eth0 and bring up the network card using the same IP address, you will still need to re-register the phones, which won’t be able to find your new NIC until their ARP cache has invalidated. If the extensions are local, as in all on the local LAN, they will have to be rebooted to reestablish contact.

Also, you can’t have two default routes established at the same time, and Linux identifies the local interface as the gateway on the local machine.

As far as your activation - you’ve changed the hardware profile so you will need to move your activation to your new configuration. You should be able to do this through the FreePBX website.

yes i forgot the phones are all linked to that IP
so really i need to switch the IP addressed around and reboot the system
then down eth0 and it should work.

That might work.

A more complicated answer would be to change the address the phones connect so that you have a primary and an alternate. That’s an entirely new level of pain that you probably want to avoid, but it would also get your phones to connect.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.