Renamed: IAX Oddity


(John Jarrett) #1

I know, I know that I should do a pjsip trunk between my point to point FPX boxes but IAX has just worked. I just did an install of FPX 15 on an unknown celeron micro ITX board off of eBay and did a restore from a backup of my current fully functioning FPBX system. I must tell you the restore was perfect. Everything I had entered and set was there in the restored PC. I have compared every and I mean every setting of both FPXes… multiple times.

My Flowroute PJSIP trunk and my SIP trunk work fine, all extensions work great, calls in and out via the PSTN work great no issues. Well I never did check my IAX and today when I did, “all circuits are busy”. No joy in or out via IAX. Both remote and local have the same message and can’t connect

Both ends show IAX connected. Remote end is a FPBX 14 and local are both15, both the backed up and restored boxes. I reset both FPXes both firewall routers (VPN into the remote site) and no joy. I then scoured the aaterisk full log. No real errors other than cannot connect to an endpoint or no endpoint found or similar logged message/error. Like no connection at all was present or created. After no endpoint found it would then go through the hang up sequence and play the congestion message also seen in the log.

When I put my backed up… the old FPBX, back in the network, it all works just fine.

Any thoughts and what’s missing? From both ends IAX shows connected. Ping and response times show good. The new FPBX uses the same IP, with the old one shut down.

Hope all this makes sense and again, thank-you so much for any thoughts. What did I and/or the backup/restore miss?

John


(Dave Burgess) #2

This one is probably going to show up in the /var/log/asterisk/full log. The failure of the call between the IAX2 trunks should be pretty obvious.


(John Jarrett) #3

Thanks Dave for the reply. That’s where I looked and the only thing seen of error status was no endpoint found, or similar, in that log. It was a normal dial, then no endpoint found, then congestion message and hang up. This has me really stumped!


(Dave Burgess) #4

Sounds like you’re missing the outbound route. The trunk just connects the lines, the outbound route is what routes the ‘non-native’ calls to the other PBX.


(John Jarrett) #5

Thank-you again Dave! I really do appreciated the suggestions.

The route is there, been there and is configured exactly as my in-use FPBX… set to the IAX trunk. Also in case you missed it, the remote end, when I dial a local extension remotely, does the exact same thing as when I dial a remote extension locally!!! Argh!!! Put the production local box in and no issues at all.

I have literally poured over the log and compared every setting… I am dumbfounded and I am truly fearful it will be something simple, if that is something to fear?!

John


(John Jarrett) #6

I have been messing with the issue for several days off and on trying to figure out why IX shows connected but never works. The mystery is solved, sort of, and I am wondering if my theory might be correct or if by chance it just started to work!

In testing this box I always shutdown my production FreePBX. Still plugged in and in still plugged into the network but powered off. I would then change my test box to the production FreePBX IP restart the network service and for good measure I would reboot it. Everytime in this scenario IAX would show connected between my two boxes, one 180 miles away, but I would always get the standard congestion message. The logs would simply show “no endpoint”.

I started thinking, (sometimes bad in my case), that network switches do not route but they sort of do by keeping a MAC address table and sending packets meant for that MAC to that specific MAC. If my network card was still ‘active’ or in a sleep mode by being powered off, (and when my prodcution server is off the LEDs by the network connector still blink away), would my switch somehow be sending those packets to the computer with the known MAC address in its table? Unlikely as everything else was working just fine, regular calls via my trunks.

Today I shutdown my production FreePBX and unplugged the network cable. Fired up the test box, set the IP, restarted the network service, rebooted just for good measure, (I know don’t have to do a reboot… usually), and EVERYTHING WORKED!

What the …

So, how is this possible? Go from a non working IAX link with everything else working to a working IAX link!!

I KNOW there are really smart guys who will have some thoughts on this and I am so wanting to learn.

Anyway… solved or at least it is working!

John


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.