Removed extension but get "A route with this DID/CID:NumberInQuestion already exists" when trying to reuse

Debian 6.1
dahdi-linux-complete-2.6.1+2.6.1
asterisk 1.6.2.11
asterisk-addons 1.6.2.4
freepbx 2.8.0

I completely removed an extension for a user because the wrong number was put in for that user. (yes I have gone through manually to check it is indeed not used in any other extension) When I try to use that DID for a new user I get “A route with this DID/CID:NumberInQuestion already exists”.
Doing a grep on the asterisk dir I have found that the extension indeed still exists in
extensions_additional.conf
and
voicemail.conf
I understand this problem has probably been resolved in newer versions. However this configuration of versions is the only one that worked for our hardware/linux/setup. So please no “Upgrade to X” replies, or flame replies with no helpful information. My question here is, if I just remove the references and or left over extension problems in the conf files, will this fix the problem? Or do I have to remove it somewhere in the FreePbx database as well? I am looking for a manual bandaid fix, not a solution to this happening in the future.
Thank you

Did you remote the inbound route for the DID?

Awesome! That worked great, I never realized it created a separate inbound DID route. It sure is a good thing I would rather feel dumb and have the problem solved, than be stuck with problems.
Thank you again!