Remove parts of VM-Notify


I have bought VM-Notify and want to change the prompts to our language.

However when I change the initial greeting to the WAV in my language it still reads the extension number in English after playing the greeting. How can I change this to my language as well or better yet totally remove it?

Thanks in advance.

You actually need to set the PBX’s default language to your language and make sure the right language sound pack is installed. Then the standard system recordings will be in your language.

The default language is the prefered language. Everything else (like wrong inputs in ivr) are all in my language. The whole PBX is converted but not VM-NOTIFY. This one just keeps English no matter what. I even used the sound files that come with FreePBX to double check and then the whole PBX changes to that language but NOT VM-NOTIFY.

So I appreciate your response but thats not the issue here :slight_smile:

Actually, it is. Are you a 100% sure that your language pack has those recordings in that language? If it doesn’t exist in the language pack then the system will revert to the standard defaults, which are in English. In order for you to change them to your language you have to have those recordings for the VM Notify in your language pack.

And if they don’t exist, you can just create them and add them. The only issue will be they won’t have the same voice as the result of the “default” system recordings in the pack.

VM-Notify reads back the numbers as “One, Two, Three”. While the other operations use my language. However I am willing to make custom languages but is there a manual to do this?

Like what are the file names and locations to put them? It’s rather annoying to have the announcement be in my language and to have VM-NOTIFY follow up with english numbers. Even just replacing it with empty .wav files would solve my issue in this.

VM-Notify is a third party module be it the free version or the commercial version. The language packs are based on the free/included files that come with Asterisk. Anything a third party adds/modifies/etc is up to the third party to consider multiple language support.

So basicly I payed money for a module that sangoma hasn’t made multi language and has no documentation available on how to do it yourself… aight thanks :sunny:

I am relatively sure multi language can be made to work. Please open a support ticket of type commercial modules so we can investigate.

1 Like

Dear Igaetz,

I followed your advice and the “solution” offered was to go to Settings > Voicemail admin > Settings and put Say CID to NO… Which is clearly a voicemail function and not a VM Notify solution. So even if this fixed the issue (Which offcourse it didn’t…) it wasn’t a solution.

So what is left for me is an email where I’m told I need to have Support Credit or a Support contract for further support…

EIther the support employee doesn’t read my ticket/understand my problem (I tried to explain it in several ways and I get offered solutions I allready tried) or it’s just something incredible difficult I am asking and I need to pay money for support on a commercial module which, has never stated on the website, would only work in English…

Since support isn’t capable of helping me I am going further into trying to fix this myself.
We don’t use English on this PBX so would it be a solution to overwrite the English numbers with the numbers I have in my language? I was thinking about overwriting the file in the /var/lib/asterisk/sounds/en and en_GB with the sound files I have in my language.Or would asterisk skip this reading back if I deleted these files all together?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.