Remove extension from outbound route


(Fbedia) #1

I am trying to make an outgoing call through the trunk.

My extension is: 1001
The called number: 666123123

The call is not completed… and the trunk provider tells me that the problem is that I am presenting my extension “1001” in the “From” and they send me the following log:

Dec 4 09:11:38 kamailio-empresas-2 kamailio[5757]: NOTICE:script | 1cace172-2b8b-4c29-ba0c-cd231cc56ae0 | call-out | cli: user provided cli ‘From: 1001’ is not valid and no default cli | c:trunk/cF42847_2/80.80.800.8 | n:666123123/1001 | =>403

How can I avoid sending the extension?

I attach my outbound route configuration…
Maybe i need some change in /CallerID section?

Thanks!


#2

In the settings for extension 1001, the Outbound CID field should be something like:
"John Doe" <666234234>"
where 666234234 is the caller ID you wish to send.

In the Route Settings for the Outbound Route, Override Extension should be set to No (assuming that you want the CID for the extension to be sent).

In the General settings for the Trunk, Allow Any CID should be set (assuming that you want the CID for the extension to be sent).

Assuming that the provider will accept the caller ID in the From header, From User should be blank (pjsip trunk), or the fromuser parameter should not be present (chan_sip trunk).


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.