Remote SIP Extension


Since the release of Free PBX 2.5, has anything changed as far as settings for remote SIP extensions ?

I built a new system yesterday using Trixbox and upgraded to the latest FreePBX 2.5… very funky…

All my internal extensions work no problem but I configured an external SIP extension today and just can not get it to register.

I have built somewhere in my 20’s or Trixbox systems majority of which have external SIP extensions. We manage all the firewalls ( WatchGuard ) for customers and create seperate custom rules for both 5060 and 10000 - 20000 ports NATing to the internal IP address of the Trixbox.

I have re-checked the How To @ to see if anything has changed but it dosn’t look like it has.

Anyone have any idea’s, i am sure my config is correct, i have also tried setting up an X-Lite softphone from another office with a site to site VPN ( i.e. all ports open ) and although that does register I am only getting one way voice ( from the LAN with the trixbox )

I can also confirm that my sip_nat.conf file has also been setup with the correct IP addresses.


one way voice is the classic sign of not having the Nat setup correctly. You should make sure that you have nat=yes in the sip_nat.conf file. and make sure that the extension has yes set for nat.

Also some older firewalls do not work well allowing sip through the far side nat so check the remote site firewall as you might need to port forward 5060 to the phone.