Remote Phones seem to connect to PBX but don't register

We have a remote location where the phones were working fine but stopped recently. I’m having trouble getting all 3 of them back online. I was able to get one Digium D40 phone to register and work as expected at the remote office, however, another Digium D40 and a Sangoma S500 seem to connect to the PBX but not register.

On the D40, the phone appears to connect to the PBX but when dialing an internal extension or external number there is just silence and no connection. The phone also does not appear as a Chan_SIP peer on the PBX. If I change one small thing in the SIP settings (change one digit of the password, extension number, port, or IP address to be incorrect) the call will fail and I get a fail tone when trying to place a call. I have reset the phone to factory and re-entered the config, that didn’t solve it.

On the Sangoma S500, I reset the phone to factory settings then had it auto-provision. The phone found the config and even downloaded our company logo. But, the extension in the upper right had the red line through it and the phone would not place a call. It also would show an “unknown” status on the chan_SIP peers report on the PBX server.

I have the IP for the remote office in the whitelist on System Admin>Intrusion Detection (and restarted intrusion detection) and in the Trusted Zone on the firewall. I have also confirmed that it is not a blocked host on the firewall and not banned on intrusion detection. I event disabled intrusion detection and the firewall while attempting to connect the phone. Neither worked. I also rebooted the PBX server twice and the phones countless times. Mind you, there is a D40 phone at this remote office that connects and works as expected.

I then brought the phones back to the office where the PBX server is. I used my cell phone hot spot and an ASUS RT-N66U router in repeater mode to create an external network separate from the PBX server. I plugged the phones into this external network and they connected and worked perfectly. I did not change any settings between them not working at the remote office and them working on the Hot Spot external network.

I’m at a loss as to why these phones will work on my external hot spot network but not the remote office network, yet there is another phone at the remote office that works. Any ideas where I should start looking?


My guess is that your far end router does not handle sip well, make sure any sip ‘helpers’ are disabled

rasterisk -x ‘sip show peers’

should show that all your extensions are on different ip addresses AND ports

Thanks, Dicko.

When the phones were plugged in at the remote office they did not register on ‘sip show peers’. The extension showed:

9141 (Unspecified) D Yes Yes A 0 UNKNOWN

The router at the remote office is also the same router used at the office with the server and the router used with my hot spot network (ASUS RT-N66U). I have NAT passthrough for SIP disabled on all of the routers.

then go to sip debugging, no other way really

Well, I went out to the remote office to do a SIP debug. I plugged the phone in and it worked. Not sure what the issue was. I’m wondering if the firewall or Fail2Ban put the device in a “jail” for a specified time period or something.

Thanks for the help!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.