Remote phone access to server

Hi, I’am new to this platform but Im excited to explore. May I ask for some help on how can I connect ip phones to my freepbx server from the remote location? I already set vpn and connected to the branch office. But not on my freepbx server, only in my freepbx server. Thank you.

I don’t think there should have been two freepbx’s in that sentence!

This isn’t really a Freepbx issue its simple networking…if you have a site to site always on vpn connection setup from your remote office to your main office where your freepbx sits…and you have the correct subnet that your freepbx sits on exported and available over the vpn…then you don’t need to do anything special to register your phones…can you ping the freepbx server from the remote office? If not, you don’t have your vpn/network setup correctly.

If you are not using a site to site vpn, and are using Sangoma phones, you can turn on the built in vpn client in the phone and enable vpn in freepbx…

Hi, I use ipsec vpn. Everything seems working because they can share files, ping the server’s ip address everything but only the freepbx server is not. Subnet and ip adddress is correct also the gateway.

First, if you can’t ping the FreePBX server on the other network you have networking issues. Did you setup the FreePBX firewall? If so, you may have restricted login to FreePBX to the local subnet. Check there first.

Then…to register phones to the PBX check this setting too.

Go-to the “Settings” menu, “Asterisk SIP Settings”

Under NAT settings make sure both subnets for each location are added in there.

Hi, May I ask where can I do the firewall configuration? Thank you.

I don’t use the FreePBX firewall but it’s located under “Connectivity” -> Firewall. I suggest you disable it and test it. Then reable when you set it up for your networks.


Thank you for that. But I already tried to disable but still the same. But I think i found the answer. Maybe it’s because of NAT settings. My vpn settings is NAT disabled to access my router. Freepbx is NAT enabled. I’am not 100% sure with this. Again thank you very much!!!

Normally VPNs are local networks and should be listed as local networks in your configuration.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.