Remote extension wont ring

Dear all,
when I call from any extension to a remote extension I get congetion tone and the remote extension wont ring. on the other hand when i call from the remote extension to any extension in the same lan as asterisk i have no problem. the following text is the asterisk -r:

Verbosity is at least 3
trixbox1CLI>
trixbox1
CLI>
trixbox1CLI>
– Executing [[email protected]:1] Macro(“SIP/200-0849ddb0”, “exten-vm|novm|266”) in new stack
– Executing [[email protected]:1] Macro(“SIP/200-0849ddb0”, “user-callerid”) in new stack
– Executing [[email protected]:1] NoOp(“SIP/200-0849ddb0”, “user-callerid: device 200”) in new stack
– Executing [[email protected]:2] Set(“SIP/200-0849ddb0”, “AMPUSER=200”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/200-0849ddb0”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/200-0849ddb0”, “1|Set|REALCALLERIDNUM=200”) in new stack
– Executing [[email protected]:5] NoOp(“SIP/200-0849ddb0”, “REALCALLERIDNUM is 200”) in new stack
– Executing [[email protected]:6] Set(“SIP/200-0849ddb0”, “AMPUSER=200”) in new stack
– Executing [[email protected]:7] Set(“SIP/200-0849ddb0”, “AMPUSERCIDNAME=Office Test”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/200-0849ddb0”, “0?report”) in new stack
– Executing [[email protected]:9] Set(“SIP/200-0849ddb0”, “AMPUSERCID=200”) in new stack
– Executing [[email protected]:10] Set(“SIP/200-0849ddb0”, “CALLERID(all)=“Office Test” <200>”) in new stack
– Executing [[email protected]:11] Set(“SIP/200-0849ddb0”, “REALCALLERIDNUM=200”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/200-0849ddb0”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:13] NoOp(“SIP/200-0849ddb0”, “TTL: ARG1: novm”) in new stack
– Executing [[email protected]:14] GotoIf(“SIP/200-0849ddb0”, “0?continue”) in new stack
– Executing [[email protected]:15] Set(“SIP/200-0849ddb0”, “__TTL=64”) in new stack
– Executing [[email protected]:16] GotoIf(“SIP/200-0849ddb0”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“SIP/200-0849ddb0”, “Using CallerID “Office Test” <200>”) in new stack
– Executing [[email protected]:2] Set(“SIP/200-0849ddb0”, “RingGroupMethod=none”) in new stack
– Executing [[email protected]:3] Set(“SIP/200-0849ddb0”, “VMBOX=novm”) in new stack
– Executing [[email protected]:4] Set(“SIP/200-0849ddb0”, “EXTTOCALL=266”) in new stack
– Executing [[email protected]:5] Set(“SIP/200-0849ddb0”, “CFUEXT=”) in new stack
– Executing [[email protected]:6] Set(“SIP/200-0849ddb0”, “CFBEXT=”) in new stack
– Executing [[email protected]:7] Set(“SIP/200-0849ddb0”, “RT=”"") in new stack
– Executing [[email protected]:8] Macro(“SIP/200-0849ddb0”, “record-enable|266|IN”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/200-0849ddb0”, “0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“SIP/200-0849ddb0”, “recordingcheck|20090222-220000|1235332800.32”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20090222-220000|1235332800.32: Inbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] NoOp(“SIP/200-0849ddb0”, “No recording needed”) in new stack
– Executing [[email protected]:9] Macro(“SIP/200-0849ddb0”, “dial||tr|266”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/200-0849ddb0”, “1?dial”) in new stack
– Goto (macro-dial,s,3)
– Executing [[email protected]:3] AGI(“SIP/200-0849ddb0”, “dialparties.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
dialparties.agi: Starting New Dialparties.agi
== Parsing ‘/etc/asterisk/manager.conf’:Found
== Parsing ‘/etc/asterisk/manager_additional.conf’:Found
== Parsing ‘/etc/asterisk/manager_custom.conf’:Found
== Manager ‘admin’ logged on from 127.0.0.1
dialparties.agi: Caller ID name is ‘Office Test’ number is '200’
dialparties.agi: Methodology of ring is ‘none’
– dialparties.agi: Added extension 266 to extension map
– dialparties.agi: Extension 266 cf is disabled
– dialparties.agi: Extension 266 do not disturb is disabled
– dialparties.agi: dbset CALLTRACE/266 to 200
– dialparties.agi: Filtered ARG3: 266
== Manager ‘admin’ logged off from 127.0.0.1
– AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:7] Dial(“SIP/200-0849ddb0”, “SIP/266||tr”) in new stack
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:8] Set(“SIP/200-0849ddb0”, “DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:10] Set(“SIP/200-0849ddb0”, “SV_DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:11] GosubIf(“SIP/200-0849ddb0”, “0?docfu|1”) in new stack
– Executing [[email protected]:12] GosubIf(“SIP/200-0849ddb0”, “0?docfb|1”) in new stack
– Executing [[email protected]:13] Set(“SIP/200-0849ddb0”, “DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:14] NoOp(“SIP/200-0849ddb0”, “Voicemail is novm”) in new stack
– Executing [[email protected]:15] GotoIf(“SIP/200-0849ddb0”, “1?s-CHANUNAVAIL|1”) in new stack
– Goto (macro-exten-vm,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] PlayTones(“SIP/200-0849ddb0”, “congestion”) in new stack
– Executing [[email protected]:2] Congestion(“SIP/200-0849ddb0”, “10”) in new stack
== Spawn extension (macro-exten-vm, s-CHANUNAVAIL, 2) exited non-zero on ‘SIP/200-0849ddb0’ in macro ‘exten-vm’
== Spawn extension (macro-exten-vm, s-CHANUNAVAIL, 2) exited non-zero on 'SIP/200-0849ddb0’
trixbox1
CLI>

do you have any ideas? Also when I call a iax remote extension i have no problem…

Thanks in advance,

george drepaniotis

search for sip_nat.conf
search for rtp