Remote Extension Registration Failure FreePBX 16

Hello. I have searched this topic all day, but none of the answers seem to apply to the parameters that are accessible in freePBX 16.

I have recently rebuilt a freePBX system from scratch, due to a hardware failure of a working system.

Everything is working - trunks via Sipstation, multiple extensions onsite. However, when I try to register a remote extension (something that previously worked under an earlier version of freePBX), there is no response from the freePBX computer.

These are two different tcpdump examples, both from exactly the same endpoint.

When using the extension on the local network:
“13:53:19.753033 IP NAMEOFMYROUTER.57377 > FreePBX.sip: SIP: REGISTER sip:FQDN:5060;transport=UDP SIP/2.0
13:53:19.756087 IP FreePBX.sip > NAMEOFMYROUTER.57377: SIP: SIP/2.0 200 OK
13:53:19.757140 IP FreePBX.sip > NAMEOFMYROUTER.57377: SIP: OPTIONS sip:username@ADDRESSOFMYROUTER:57377;rinstance=216d2dd8c22144e0 SIP/2.0
13:53:19.762205 IP NAMEOFMYROUTER.57377 > FreePBX.sip: SIP: SIP/2.0 200 OK”

When using an external network, this (and eventually a time out error on my extension):
“13:53:00.778124 IP MY_EXTERNAL_IP.12450 > FreePBX.sip: SIP: REGISTER;transport=UDP SIP/2.0
13:53:01.278161 IP MY_EXTERNAL_IP.12450 > FreePBX.sip: SIP: REGISTER;transport=UDP SIP/2.0
13:53:02.298693 IP MY_EXTERNAL_IP.12450 > FreePBX.sip: SIP: REGISTER;transport=UDP SIP/2.0”

Is it possible on freepbx 16 to have remote extensions? Or has this been removed for security?

Thanks for any help or pointers.

Remote extensions work great on FreePBX still.

I am not completely understanding these dumps. Are you not seeing anything in the asterisk logs when the extension tries to register?

I would check your firewalls (both the FreePBX one and the hardware firewall that sits in front of the FreePBX) to make sure you are forwarding the correct SIP ports for the new PBX and allowing connections from the external IP of the extension that’s not working.

I am not seeing anything in the asterisk logs when the extension tries to register. If I switch to the local network, I immediately get an ENDPOINT REGISTERED message, but if I try the same thing from a remote network I don’t get any response at all.

The reason I showed the tcpdump information is to show that the registration attempts are making it all the way to the freepbx server. If they were blocked by a previous firewall, they wouldn’t be showing up there at all.

Currently, I have not set up a firewall on the freepbx server. I planned to set that up after I had successfully registered the remote phones.

Any idea where I should look next?

What is your verbosity level of the asterisk log set to? You can get that info by running core show settings in the asterisk CLI and looking for the Current console verbosity: line towards the top. It could be that errors related to extension registrations are suppressed.

Another way to monitor connection/registration events is by running sngrep from the Linux CLI and filtering by extension with F7 and specifying the extension in the SIP From field. I find that a bit easier to parse then tcpdump output (unless I am looking at it in Wireshark).

"2023/07/05 16:10:44.107164 MY_PHONE_IP_ADDRESS:14080 → PBX_ADDRESS:5060
REGISTER sip:FQDN:5060;transport=UDP SIP/2.0
Via: SIP/2.0/UDP PRIVATE_NETWORK_IP:57377;branch=z9hG4bK-524287-1—96cca49c9d782098;r
Max-Forwards: 70
Contact: sip:705atPRIVATE_NETWORK_IP:57377;rinstance=ac3a594839ce23bb;transport=UDP
To: sip:705atFQDN:5060;transport=UDP
From: sip:705atFQDN:5060;transport=UDP;tag=a352e855
Call-ID: itxB8W68pKmt-UGcJ6XWkQ…
Expires: 60
Supported: replaces, norefersub, extended-refer, timer, sec-agree, outbound, pat
User-Agent: Zoiper v2
Allow-Events: presence, kpml, talk, as-feature-event
Content-Length: 0

Verbosity was set to 4.

Cisco and NAT does not mix.

Legacy Cisco’s and UDP also have been problematic.

No Cisco phone used here. I’m trying to connect with Zoiper (for ease of switching from in and out of network), and Sangoma phones.

I saw Cisco but didn’t check where it was, exactly.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.