FreePBX | Register | Issues | Wiki | Portal | Support

Remote extension randomly UNREACHABLE


(CCTS) #1

I have a client we’re having some issues at. When I check Asterisk info > peers I see that their extensions randomly show UNREACHABLE.

the environment:
-I have a poe switch and 5 phones on-site, connected to my cloud hosted fpbx.
-I have no control over their router (it’s managed by their IT vendor)
-they have a static ip
-their router is doing dhcp & nat
-cloud hosted fpbx 13, NAT set to yes on the extensions

Most of the time their extensions show OK, but sometimes a random phone will show UNREACHABLE.

Which causes that phone to not ring on an incoming call & is causing lots of frustration for me and the client. So outside of putting a fpbx on premise or getting them to get an additional static ip and I can separate phone/data lans & put in my own router, what are my options here? what else should I check


(CCTS) #2

oh and we’re using Yealink SIP-T29G phones provisioned thru EPM.


(Tom Ray) #3

This is a NAT is with the router in front of the phones. The IT people need to look at it.


#4

Try frequently refreshing the registration. I don’t know which setting this is in the template, but believe that in the phones it’s
Account (e.g. Account 1) -> Register -> SIP Server 1 -> Server Expires.

I believe that the default is 3600; try setting it to 120 or even 60 (seconds).


(CCTS) #5

Ok, so what’s the best practice for remote phones with this NAT issue?

Make changes to the firewall? If so, what changes need to be made on the firewall? Static lan ip for the phones and port forwarding?

or

change the register expires on the phones?

or something else?


(CCTS) #6

I can manually change the reg expires on the phones, but how to change that on the EPM template? It would be best to change it there and then just update the phones from the fpbx rather than logging into the gui for each phone and changing it.


(CCTS) #7

Well I did some more digging while onsite, and it looks like the At&t (their isp) modem is doing nat & dhcp, so I now have options…I can install my own router behind it & forward all sip/rtp traffic to my router or make some config changes to the ATT modem and just connect my phones directly to it.


(CCTS) #8

Thanks for your suggestions, I opted to put in my own ER-X behind the att modem & put the att modem in ip passthrough mode to my edgerouter & all is well now.


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.