Remote Extension not in ACL List

I am attempting to add a remote extension, however it will not register.
When I look at the asterisk log files it says extension 104 not in ACL list,


Any help would be great.


Have you read this?

Yes I did read the “how to” but I did not think that was the issue because the remote extension was communicating with the FreePBX server.

However I will try if you think that is the problem.

Thanks for the reply


When I changed sip_nat.conf to:
localnet=192,168.1.0/ or localnet=

my outbound trunks show UNREACHABLE under asterisk info, Sip Peers.
and I get a recording ALL CIRCUITS ARE BUSY when attempting a call


Do you have any permit or deny variables in your peer definition? I am trying to figure out where you have the ACL configured.

You want to set a global nat=yes in sip_nat.conf

Is your externip the IP address that is used for outbound NAT (ignore this question if you have only one static IP) ?

Your first localnet setting has a typo, there is a comma after the first octec. The argument of a localnet setting is a network number not a host in the network so your second statement will not exclude local traffic from the NAT policy.

The definition of localnet is traffic that is to be excluded from the Asterisk NAT process.

Valid localnet for class C network

YOu could exclude all 192 address with a 16 bit class B mast like this:

You can get as tricky as you want summarizing networks. It’s best however to have a localnet declaration for each subnet. You can have as many as you need.