Remote Cisco 7961G Not regerstering

Hello everyone! Happy Friday!
I have been maintaining a FreePBX system for a client for about 5 years now. A little back ground info: have rebuilt the system from the ground up as it was horribly outdated within that time, and have kept it updated regularly. They have been utilizing Cisco 7960’s which have stood the test of time with little to no issues. However without consulting me the owner purchased a 7961G to be used as a remote extension. While I have already configured a 7960 for a remote extension successfully and works great! This 7961G is giving me all kinds of headaches. The first being it utilizes XML files instead of the simple text based files. I flashed it to the current firmware for SIP protocol, configured the extension with the correct password in FreePBX but when I attempt to register it from home, it connects successfully pulls the config.xml files successfully from tftp but when registering I can see in the logs that it registered successfully then a second later I get an error registration failed. However I can make calls with no audio, but do not receive them from followme ring plan. In FreePBX the phone remains marked as unreachable. I have tried configuring my home modem with the same settings I used to set up the 7960 remotely which have not worked. Does anyone have any suggestions? I keep thinking its a firewall and NAT issues, but I’ve tried every setting I can think of. I appreciate any input, and thank you in advance.

I was wondering if you ever succeeded in getting the 7961G to work with FreePBX. I have two phones I just pickedup, and can get them through the TFTP phase all the way up to registration, where it seems to fail. I can see all of the button assignments, but where there are phone lines, there is still the “x” in the picture meaning if failed to register. I also do not see the phones where the peers are listed in FreePBX. I am attempting to get the 7961G to work, because I have two 7914’s that won’t work with FreePBX and SIP using the 7960 phones.

Hello to all
I too have the same problem, I have given 10 ip phones cisco 7961g and 5 cisco 7911g, I would like to run them with freepbx, but I can not. I tried with different firmware but nothing, the “x” remains in the display. You help me thanks!

Try using a shorter password.

Hello, thanks for the reply.
At the moment I use a 5-letter password.
I tried with different firmware, both for the cisco 7961 and for the cisco 7911, I can not. I am using FreePBX I would be grateful if you would favor a firmware and a complete and working configuration. Thank you!

What do you see in the asterisk logs when using a short password?
Also, you can check Intrusion Detection if the phone got banned.

now I changed my password, I entered a 7-character one.
How can I monitor intrusion detection?

Admin > System Admin > Intrusion Detection.

If you are not banned, monitor asterisk to see if the phone is even trying to register, and post the logs here.

asterisk -rvvv